Forums » Support

Back To Topics

Profile Designer

    • 143 posts
    October 13, 2015 1:29 PM CEST

    Are you on iOS or Android? I think that will be an app problem.

  • October 12, 2015 9:21 PM CEST

    That's what I did. I edited a profile in the profil designer, It shows up in My profils in the profile market, but the shanges are not there, unless I change the name of the profile. If I delete the profiles from the profile desighner, my profiles in the market, and from my creation. They still show up when I click add new profile. How can I remove them from there?

    • 143 posts
    October 12, 2015 12:58 PM CEST

    Hi Pete,

    First: You have to update the profile in the market's your profiles section.

    Second: If you deleted the profile from the PD, but it's downloaded and added to one of your creations, then it stays until you remove it manually.

     

  • October 11, 2015 9:45 PM CEST

    I was playing around with the profile designer, and noticed a couple of minor issues. First, when I try to save an edited profile, it seems to save and shows up in my profiles, however when I try to add it as a new profile to me creation, the changes don't apppear. Second, when I delete profiles, they still show up in a list when I try to add a new profile to a creation. Is there something I'm missing?

    Pete

    • 164 posts
    October 7, 2015 5:02 PM CEST

    Hi Guido,

    The new features are expected in November ;)

    • 2 posts
    October 3, 2015 9:37 PM CEST

    [blockquote]Lénárd Pásztor said:

    [blockquote]x x said:

    Hi,

    how i control PF-lights, like turn signals are required to blink on and off or brake lights?

    thanks

    x x

    [/blockquote]

    Hi,

    This feature is not implemented yet in the profile designer. We are working hard to make new features in the profile designer, like LED controls.

    [/blockquote]

     

    I just ordered another 4 SBricks to control various functions in a train/city layout. I am still missing some degree of automatization such as blinking, programmable sequences, random flickering (fire!) etc. that can be assigned to SBrick ports and turned on/off with a button. Any news on this?

    Guido

    • 143 posts
    September 29, 2015 2:40 PM CEST

    [blockquote]Jakob Peterhänsel said:

    [blockquote]Tamas Misik said:

    Jakob, Thanks for your suggestions. Unfortunately you can't give "seperate names" to two diferent control if you want to use them with the same port. 

    [/blockquote]

    Well, it used to be like that - the 'cosmetic name' is one thing, the 'channel' is another.

    Right now, the two fields is hard-linked - so why have both??? (if that is the case..)

    [/blockquote]

    They are not totally linked with each other. If you change the control's name, it will change the channel, but you can also set the channel name independently.

  • September 29, 2015 2:30 PM CEST

    [blockquote]Tamas Misik said:

    Jakob, Thanks for your suggestions. Unfortunately you can't give "seperate names" to two diferent control if you want to use them with the same port. 

    [/blockquote]

    Well, it used to be like that - the 'cosmetic name' is one thing, the 'channel' is another.

    Right now, the two fields is hard-linked - so why have both??? (if that is the case..)

     

    • 164 posts
    September 29, 2015 1:49 PM CEST

    Nelson, the joystickprofil isn't available at the moment, but it will available in the future again.

    Jakob, Thanks for your suggestions. Unfortunately you can't give "seperate names" to two diferent control if you want to use them with the same port. 


  • September 28, 2015 6:27 PM CEST

    Just did a new profile yesterday (https://designer.sbrick.com/?profile=4276) and miss two things in that process:

    1: Naming vs. channel name.
    The name seems to be forced into the channelname, meaning you now need to have the channelname as the controlname - that is not vey productive!

    In my case, I have two buttons for each channel, each sening 1 or -1 out, and I would like to have seperate names for the two controls, making it easier to select in the list.. That used to be the case, so bug?

    2: Multiselct = delete/move/duplicate items :-)
    Making two controls that needs to be dubplicated 3 times, would ease creation, right now you need to create all items and set then all up one-by-one.. tedious.. :-/

    • 1 posts
    September 25, 2015 4:18 PM CEST
    HI guys, I just received my 3rd sbrick (so exited) I love it so far but I've had a hard time trying to find the joystick profile (the one tamas is using on the model 8070 ) how can I get it for my galaxy s5 and iPhone 5s ? Thank you.
    • 99 posts
    September 2, 2015 12:32 AM CEST

    It looks good ! Wil try that next week-end for sure :)

    • 143 posts
    September 1, 2015 3:24 PM CEST

    Hi Everyone,

    The new Profile Designer version is out in the wild. We made some design changes, as well lot of bugfix and perfomance fix.

    The biggest thing is that the minimap is gone. Since the  workspace is always fit into the browser initial size there is no need.
    Also, the sidebar is cleaned up, we need that free space for future improvements.

    Bugfixes:
    - We had issues with control deletions, that caused the effect when the close button, or the background duplicated, and the controls didn't work on the devices.
    - Several fixes here and there.

    If you find any error, don't hesitate to share with us!

    The wiki is updated as well: https://social.sbrick.com/wiki/view/pageId/10/slug/user-guide-for-profile-designer

    • 143 posts
    August 11, 2015 3:54 PM CEST

    [blockquote]Uwe Steffan said:

    By the way, how do you place the functionicons to the background 

    [/blockquote]

    Which one do you think? :)

    • 7 posts
    August 10, 2015 11:14 PM CEST

    Hi there,

    Currently you can't add or remove the Close button. Your problems seems rare to me, would you be so kind to provide me some more information?
    - What browser do you use, and what's your profile ID?
    - Do you have any plugins in your browser? (i'm courius about content blockers)

    Hi Zsolt!

    I have removed my design and rebuild it new. It works now very well. The ID is 3427.

    Normaly I use the most used browser mozilla firefox, sometimes IE.

    I have installed google chrome only for using your designer.

    No plugins.

    By the way, how do you place the functionicons to the background 

    • 143 posts
    August 10, 2015 6:25 PM CEST

    [blockquote]Jurgen Krooshoop said:

    [blockquote]Zsolt Szrapkó said:

    I checked it, and it seems ok until the Joystick, but you should set the Sliders channel parameter too. The Name parameter is just a cosmetic thing in the Profile Designer. We know it's not obvious, and we're working on a more accurate way. (Also, bigger features coming soon).

    Anyway, if you can't set the channel parameter, try to empty your browsers cache, maybe something stucked within...

    [/blockquote]

    That worked. Indeed, I only set the name, but not the channel. That also explains why all the sliders operated the same function.

    Thanks for your help !! Now I can refine the Profile. I 'm planning to put this SBricks model on display at Lego World 2015.

    [/blockquote]

    I'm glad to hear that. :) Have fun!

    • 23 posts
    August 10, 2015 6:07 PM CEST

    [blockquote]Zsolt Szrapkó said:

    I checked it, and it seems ok until the Joystick, but you should set the Sliders channel parameter too. The Name parameter is just a cosmetic thing in the Profile Designer. We know it's not obvious, and we're working on a more accurate way. (Also, bigger features coming soon).

    Anyway, if you can't set the channel parameter, try to empty your browsers cache, maybe something stucked within...

    [/blockquote]

    That worked. Indeed, I only set the name, but not the channel. That also explains why all the sliders operated the same function.

    Thanks for your help !! Now I can refine the Profile. I 'm planning to put this SBrick-model on display at Lego World 2015.


    This post was edited by Jurgen Krooshoop at August 10, 2015 7:33 PM CEST
    • 143 posts
    August 10, 2015 5:41 PM CEST

    [blockquote]Zsolt Szrapkó said:

    [blockquote]Jurgen Krooshoop said:

    [blockquote]Zsolt Szrapkó said:

    Hi Jurgen,

    Please provide me your profile's ID.

    [/blockquote]

    What exactly do you mean with Profile ID's ? 

    If it's the number in the URL of the PD, then it's: 3458

    The one in which the sliders don't work:

    https://designer.sbrick.com/?profile=3458

    The old ones that do work:

    https://designer.sbrick.com/?profile=910

    https://designer.sbrick.com/?profile=387

    [/blockquote]

    Thanks, i asked about the number :) I will look into it as soon as possible.

    [/blockquote]

    I checked it, and it seems ok until the Joystick, but you should set the Sliders channel parameter too. The Name parameter is just a cosmetic thing in the Profile Designer. We know it's not obvious, and we're working on a more accurate way. (Also, bigger features coming soon).

    Anyway, if you can't set the channel parameter, try to empty your browsers cache, maybe something stucked within...

    • 143 posts
    August 10, 2015 5:31 PM CEST

    [blockquote]Jurgen Krooshoop said:

    [blockquote]Zsolt Szrapkó said:

    Hi Jurgen,

    Please provide me your profile's ID.

    [/blockquote]

    What exactly do you mean with Profile ID's ? 

    If it's the number in the URL of the PD, then it's: 3458

    The one in which the sliders don't work:

    https://designer.sbrick.com/?profile=3458

    The old ones that do work:

    https://designer.sbrick.com/?profile=910

    https://designer.sbrick.com/?profile=387

    [/blockquote]

    Thanks, i asked about the number :) I will look into it as soon as possible.

    • 23 posts
    August 10, 2015 5:29 PM CEST

    [blockquote]Zsolt Szrapkó said:

    Hi Jurgen,

    Please provide me your profile's ID.

    [/blockquote]

    What exactly do you mean with Profile ID's ? 

    If it's the number in the URL of the PD, then it's: 3458

    The one in which the sliders don't work:

    https://designer.sbrick.com/?profile=3458

    The old ones that do work:

    https://designer.sbrick.com/?profile=910

    https://designer.sbrick.com/?profile=387

    • 143 posts
    August 10, 2015 5:17 PM CEST

    [blockquote]Jurgen Krooshoop said:

    Currently I'm having trouble designing the profile I want. I've just made an SBrick-version of my Backhoe Loader V2 and I want the profile to have 4 sliders and 2 joysticks.

    But the sliders mess things up: only the functions of the joysticks show up in the App (both Android and iOS). But only 1 sliders shows up, which is allways called "Slider", no matter what name you gave it in the Profile-Designer. 

    As a test I made a profile with only 2 sliders. It allready had these problems, and both sliders in the profile controll the same function in the MOC.

    The older profiles I have (which also have 2 or more sliders) work perfectly, So it looks like there something going wrong in the Profile-designer.

    I'm using Chrome on Win 7.

    [/blockquote]

    Hi Jurgen,

    Please provide me your profile's ID.

    • 143 posts
    August 10, 2015 5:15 PM CEST

    [blockquote]Alex G. said:

    Hi people, how can I a controller designing?

    Or how do I make the phone joystick?

    Help me, Thanks.

    [/blockquote]

    Hi there,

    You should check out the related wiki page:
    https://social.sbrick.com/wiki/view/pageId/10/slug/user-guide-for-profile-designer

    • 23 posts
    August 10, 2015 4:37 PM CEST

    Currently I'm having trouble designing the profile I want. I've just made an SBrick-version of my Backhoe Loader V2 and I want the profile to have 4 sliders and 2 joysticks.

    But the sliders mess things up: only the functions of the joysticks show up in the App (both Android and iOS). But only 1 sliders shows up, which is allways called "Slider", no matter what name you gave it in the Profile-Designer. 

    As a test I made a profile with only 2 sliders. It allready had these problems, and both sliders in the profile controll the same function in the MOC.

    The older profiles I have (which also have 2 or more sliders) work perfectly, So it looks like there something going wrong in the Profile-designer.

    I'm using Chrome on Win 7.


    This post was edited by Jurgen Krooshoop at August 10, 2015 4:39 PM CEST
    • 143 posts
    August 10, 2015 11:53 AM CEST

    [blockquote]Uwe Steffan said:

    Hi sbrick!

    While I'm playing around with the designer, the Quitbutton doesn't work anymore, so i wanted to delete an rebuild it. But where is the deletebutton? 

    And sometimes the cursor will not release the Button or slider so I carried a button out of the screen and it will not come back or rebuild new.

    So, I may have to delete my design and build it up new.

    [/blockquote]

    Hi there,

    Currently you can't add or remove the Close button. Your problems seems rare to me, would you be so kind to provide me some more information?
    - What browser do you use, and what's your profile ID?
    - Do you have any plugins in your browser? (i'm courius about content blockers)

    Thank you!

    • 3 posts
    August 9, 2015 3:36 PM CEST

    Hi people, how can I a controller designing?

    Or how do I make the phone joystick?

    Help me, Thanks.