Forums » Support

Back To Topics

Profile Designer

    • 143 posts
    June 23, 2015 4:58 PM CEST

    [blockquote]Denis H said:

    Thanks!! now is working.

     

    question not related: The output lines (-1 and 1) for the button type is for the power?  if i put +0,5 , when i press the button the engine will turn at 50% of the power?

    [/blockquote]

     

    Yes, exactly.


    This post was edited by Zsolt Szrapkó at June 23, 2015 4:59 PM CEST
    • 41 posts
    June 23, 2015 4:56 PM CEST

    Thanks!! now is working.

     

    question not related: The output lines (-1 and 1) for the button type is for the power?  if i put +0,5 , when i press the button the engine will turn at 50% of the power?

    • 143 posts
    June 23, 2015 4:20 PM CEST

    [blockquote]Zsolt Szrapkó said:

    [blockquote]Denis H said:

    There is a problem with the profile designer server???....now i can't see my custom profiles in the smartphone app - market (android). I can log in, but now there is no custom profile.

    [/blockquote]

    We're investigating the problem right now. I will update the status as soon as I can.

    [/blockquote]

    We're solved the problem, please logout and login again to see your profiles.

    • 143 posts
    June 23, 2015 1:02 PM CEST

    [blockquote]Denis H said:

    There is a problem with the profile designer server???....now i can't see my custom profiles in the smartphone app - market (android). I can log in, but now there is no custom profile.

    [/blockquote]

    We're investigating the problem right now. I will update the status as soon as I can.

    • 41 posts
    June 23, 2015 12:54 PM CEST

    There is a problem with the profile designer server???....now i can't see my custom profiles in the smartphone app - market (android). I can log in, but now there is no custom profile.

    • 143 posts
    June 16, 2015 4:19 PM CEST

    [blockquote]Denis H said:

    i'm using the android app. And i'm using in a M-Motor

    [/blockquote]

    Thank you, i'm forwarding this issue to the android developers.

    [blockquote]Denis H said:

    But what controls those values?? is the range of the sliders?

    [/blockquote]

    Yes, exactly.

    • 41 posts
    June 16, 2015 4:16 PM CEST

    i'm using the android app. And i'm using in a M-Motor

    But what controls those values?? is the range of the sliders?


    This post was edited by Denis H at June 16, 2015 4:17 PM CEST
    • 143 posts
    June 16, 2015 4:09 PM CEST

    [blockquote]Denis H said:

    I have a question.....what does VALUE config under Slider setup?....the default values for minimum and maximum are -1 and 1......but if i change to -0.5 and 0.5 all behaves the same. 

    [/blockquote]

    It allows you to fine tune these parameters, but the effect can be various, depends on the motor type. I'm just curious, which app do you use?

    • 41 posts
    June 16, 2015 3:27 PM CEST

    I have a question.....what does VALUE config under Slider setup?....the default values for minimum and maximum are -1 and 1......but if i change to -0.5 and 0.5 all behaves the same. 

    • 20 posts
    May 28, 2015 3:39 PM CEST

    [blockquote]Christian K. said:

    Need light controls realy bad ;-) Any plan when it will be available?

    Thanks

    [/blockquote]

    This is an advanced way to fix that. Change the image of a button to these photos.

    https://social.sbrick.com/albums/view/203

    • 4 posts
    May 21, 2015 7:12 PM CEST

    Need light controls realy bad ;-)

    Any plan when it will be available?

    Thanks

    • 3 posts
    May 16, 2015 4:03 PM CEST
    Hello sbrick team
    Is it an idee to make an option to put a word by a button or slidder or a joystick so that jou could se where they are ment fore

    Thank s rico
    • 57 posts
    May 12, 2015 11:46 AM CEST

    [blockquote]Zsolt Szrapkó said:

    [blockquote]Fernando Correia said:

    Unless you're planning to scale everything into the canvas autmatically.

    [/blockquote]

    That's the plan. :)

    [/blockquote]

     

    Then it is a good move! :)

    • 143 posts
    May 12, 2015 11:43 AM CEST

    [blockquote]Peter Subert said:

    Hi,

    When will you enable sharing profiles with the public?

    Thanks,

    Peter

    [/blockquote]

    We're working on it. I hope this will be available in the end of may.

    • 143 posts
    May 12, 2015 11:40 AM CEST

    [blockquote]Fernando Correia said:

    Unless you're planning to scale everything into the canvas autmatically.

    [/blockquote]

    That's the plan. :)

    • 36 posts
    May 12, 2015 5:58 AM CEST

    Hi,

    When will you enable sharing profiles with the public?

    Thanks,

    Peter

    • 57 posts
    May 11, 2015 3:11 PM CEST

    As far as I can see most problems have been fixed since the preliminar development version. Kudos!

     

    I don't see a problem with the Navigator and even find it usefull. Unless you're planning to scale everything into the canvas autmatically.

    • 143 posts
    May 11, 2015 2:37 PM CEST

    Profile Designer 1.9.6beta is out.

    Now, you have guidelines, aligned to the controls:
    - You can turn it off, and on globaly in the sidebar.
    - If you select any control, the guides shows on the other controls side, and a middle points (based on the guide settings).
    - While moving the controls, they are going to snap to the guides, and to the workspace area edges (thanks for the suggestion, Fernando!).
    - If you click on the background, the guidlines will disappear.

    Maybe you will see a strange behaviour on the rotated elements, that happens because we're use rectangles for the images, and it's totally normal at the current stage.

    Other things:
    - From now on, if you change the controls image resource, they don't loose their sizes.
    - Lot of bugfix.
     
    Next round:
    - Image element
    - I want to say goodbye to the navigator. Not totally, we have some usecase when it could be usefull, but most of the time I think it's just annoying.
    - Also, we are getting closer and closer to the final 1.0. I will update the developer roadplan later today.

    This post was edited by Zsolt Szrapkó at May 11, 2015 2:39 PM CEST
    • 57 posts
    May 1, 2015 8:31 PM CEST

    [blockquote]Nathan Evans said:

    can we put little pictures above the sliders to show us what the slider is for

    [/blockquote]

    This feature is not yet available, but we are waiting for it soon.

    Although you can always edit your own background with Photoshop, GIMP or similar. Import and than add the controls on top. ;)

    • 3 posts
    May 1, 2015 5:22 PM CEST

    can we put little pictures above the sliders to show us what the slider is for

    • 57 posts
    May 1, 2015 12:31 PM CEST

    Just tested the concept and imho it works like a charm! :)

    • 57 posts
    May 1, 2015 12:14 PM CEST

    What if you design a short height slider (e.g. width=140 and height=200)?

    Would it work for you?

    Although it goes all the way from -1 to +1, it would do it quite fast. :)


    This post was edited by Fernando Correia at May 1, 2015 12:20 PM CEST
    • 99 posts
    May 1, 2015 9:28 AM CEST

    [blockquote]Zoltan Feher said:

    After that, I tried with buttons, but I could not set 2 buttons for the same channel, and buttons are always a push-and-release to turn them on/off, the option "Auto reset" makes no sense for them from my experience :(

    [/blockquote]

    I'm not alone :)

    I tried the same approach: progressive acceleration makes sense for crawlers, but for fast cars, all we need is a basic +1/0/-1 control.

    The same layout would be useful for gearbox control (fast/slow, or upper/lower gear switch).

    It could be a new feature :

    - Temporary buttons (On/Off)

    - A button could be -1 or +1

    - Assign two buttons to the same channel

    What I use today for a 2-Speed gearbox is a small slider, but it's not always easy to catch on the fly.

    • 1 posts
    April 30, 2015 11:47 PM CEST

    Hey,

    I'm trying to create a profile where I can set up a layout where I could just turn motors to -1/0/1 (on, off, reverse) while pressing a control item.

    At first I tried with a slider, but I can not set the slider step size, so it is just not good.

    After that, I tried with buttons, but I could not set 2 buttons for the same channel, and buttons are always a push-and-release to turn them on/off, the option "Auto reset" makes no sense for them from my experience :(

    So, what could I do?

    • 143 posts
    April 28, 2015 3:07 PM CEST

    [blockquote]Henk Reinders said:

    first:

    I can delete a profile from de Profile Designer on my laptop, but the profile can I not delete from my app on my tablet.

    What can I do to delete the profiles from my tablet.

    [/blockquote]

    Everyone, if you're experience any application error, or bug on the devices, please report that on the following topics:
    Android App support: https://social.sbrick.com/forums/topic/29/sbrick-android-app
    iOS
    App support: https://social.sbrick.com/forums/topic/19/sbrick-i-os-app

    Thank you.

    [blockquote]Henk Reinders said:

    second:

    I don't understand the explionation of the Points and Values in the properties of a control item. How can I see the results of the different values in the property.

    I use Android on my tablet. 

    For the rest, the SBrick works wunderful.

    [/blockquote]
    The points and values are not visible on the Profile Designer at the moment, meanwhile, their paramters are saved into the control's settings. We are going to visualize these settings in the future.


    This post was edited by Zsolt Szrapkó at April 28, 2015 3:08 PM CEST