Forums » Support

Back To Topics

Profile Designer

    • 21 posts
    February 9, 2015 7:17 PM CET

    Thanks, NXT45R.

    I have no idea why I cannot add a background picture from within SBRICK app - nobody has yet suggested why this bug exists.

    As for the Auto-Reset...

    I don't want the slider to automatically return to the centre position because I want to be able to leave the motor running at whatever speed I choose. I do, however, want to be able to turn the motor 'OFF'. Using the slider does not actually turn the motor OFF, it just stops turning but it still receives a signal (and makes a horrible noise!).

    What I'd like is a RESET button, like in the Port Tester, which will turn OFF the motor completely (and, in an ideal world, reset the slider to zero).

     

    Other issues:

    SBRICK app always crashes and shuts down on first log-in. Re-opening the app brings trhe app back (logged in). Will TESTFLIGHT pick all these things up automatically?

     

    Thanks in advance for any guidance.

    Conor

     

     

    • 20 posts
    February 9, 2015 5:34 PM CET

    Hi guys, sorry for the double post but here are some photos I found. You can use them in the PD for light on & off. https://social.sbrick.com/albums/view/203

    • 20 posts
    February 9, 2015 3:51 PM CET

    [blockquote]Conor Davies said:

    Hi,

    just updated (via TestFlight, Ipad mini, ios 8.1.2) and have just uploaded my simple profile.

    Two issues:

    1. Still cannot select background image. I get offered 'Camera' and 'Photo library', but selecting either of these does not take me to camera or photo library. The menu for the choices simply disappears.

    2. Is there a 'reset' button available in Profile Designer, like in the port tester, please? I have a simple slider that does not 'Auto reset' (so you can take finger off ipad and motor still runs) but would like motor to turn off 'properly' when required. Sliding the slider to the middle doesn't actually turn off the motor - it just makes a whining noise without turning.

    Many thanks so far for the Profile Designer.

    [/blockquote]

    Hi Conor, here is how you can fix the problem you are having. 

    Problem Solved

    [blockquote]Peter Subert said:

    Hi Developer team,

    I tried to use the profile designer, with no success running it on w7 and Chrome, ratio irrelevant:-(.

    1. The visualization panel shows a black screen only, even if I picked any controls, they are invisible.

    2. Saving the profile was not successful at all. "Saving..." message was displayed for 10+ minutes, where I gave up:-(. Nothing was saved at the end.

    Please advise, what browsers and what devices are supported.

    However, Victory is declared: I could create my first profile using my iPad2:-).!! A few questions came up during the design:

    1. It would be great to sort objects by type in the layer view.
    2. It would be good to know, how a slider can be rotated with 90 degrees to set it horizontal looking.
    3. It would be good to add some basic graphics: e.g. colored fonts and rectangles (round, straight?), that can make it a bit more attractive and practical to group and separate controls.
    4. How can we add new graphical object styles for buttons, joystick or sliders? What are the technical requirements to include them in the library?
    Also, please let me know, how can I download the new profile to my SBrick app on my IOS devices?

    When will you publish the User Guide for the profile designer, please?

     

    P.S. How can I add screenshots to the threads? I had no such option working with FF OR Chrome on my laptop (it works fine on the iPad2 though).

    Nevertheless, it is a good start, congratulations to the whole team! Keep up with the good job!

    Cheers,

    Peter

    [/blockquote]

    Hi Peter, I don't know how to fix the first problem but here is how you fix #2.


    This post was edited by NXT45 R. at February 9, 2015 4:05 PM CET
    • 21 posts
    February 9, 2015 1:39 PM CET

    Hi,

    just updated (via TestFlight, Ipad mini, ios 8.1.2) and have just uploaded my simple profile.

    Two issues:

    1. Still cannot select background image. I get offered 'Camera' and 'Photo library', but selecting either of these does not take me to camera or photo library. The menu for the choices simply disappears.

    2. Is there a 'reset' button available in Profile Designer, like in the port tester, please? I have a simple slider that does not 'Auto reset' (so you can take finger off ipad and motor still runs) but would like motor to turn off 'properly' when required. Sliding the slider to the middle doesn't actually turn off the motor - it just makes a whining noise without turning.

     

    Many thanks so far for the Profile Designer.

     

     

    • 138 posts
    February 9, 2015 1:33 PM CET

    Hi guys. We just pushed out a new release which is fixed some bugs:

    - If your profile is freezed out the SBrick app, you should update it in the Market, we fixed it.
    - We also fixed the Problem when the controls not showed up on some aspect ratio.
    - At the start screen, you can see a "Downloads & Extras" section where you can download all the default resource files and a sample PSD.

    Fernando: I looking after this problem, Lenard also reported this behavior, but I can't reproduce it.

    Peter: Thanks for the kind words. :) We are in hard work to optimize how the Designer handling the Profiles data. I hope it will be more stable, and more responsive in this week. The User Guide is also coming soon.

    Jakob: Thanks for that link! ;)

  • February 9, 2015 9:59 AM CET

    In case you don't know your screen aspect ration:

     

    http://www.iosres.com

    • 33 posts
    February 9, 2015 4:50 AM CET

    Hi Developer team,

    I tried to use the profile designer, with no success running it on w7 and Chrome, ratio irrelevant:-(.

    1. The visualization panel shows a black screen only, even if I picked any controls, they are invisible.

    2. Saving the profile was not successful at all. "Saving..." message was displayed for 10+ minutes, where I gave up:-(. Nothing was saved at the end.

    Please advise, what browsers and what devices are supported.

    However, Victory is declared: I could create my first profile using my iPad2:-).!! A few questions came up during the design:

    • 1. It would be great to sort objects by type in the layer view.
    • 2. It would be good to know, how a slider can be rotated with 90 degrees to set it horizontal looking.
    • 3. It would be good to add some basic graphics: e.g. colored fonts and rectangles (round, straight?), that can make it a bit more attractive and practical to group and separate controls.
    • 4. How can we add new graphical object styles for buttons, joystick or sliders? What are the technical requirements to include them in the library?
    Also, please let me know, how can I download the new profile to my SBrick app on my IOS devices?

    When will you publish the User Guide for the profile designer, please?

     

    P.S. How can I add screenshots to the threads? I had no such option working with FF OR Chrome on my laptop (it works fine on the iPad2 though).

    Nevertheless, it is a good start, congratulations to the whole team! Keep up with the good job!

    Cheers,

    Peter


    This post was edited by Peter Subert at February 9, 2015 8:03 AM CET
    • 57 posts
    February 9, 2015 2:38 AM CET

    In addition to the report sent by mail, I have another behavior that I forgot to mention.

    A new profile is created and a name given. When saved it assumes the namo of one control. Eventually the latest added.

    The profile needs to be renamed afterwards in order to get the name intended. Eventually because I'm inisting to use FF... :P

    • 138 posts
    February 8, 2015 9:53 PM CET

    And another useful information: Cache is the Profile Designer biggest enemy in the beta phases. If something not working in the PD, you may have to try clear your browsers cache.

    • 138 posts
    February 8, 2015 9:38 PM CET

    You need to get the latest App both on iOS and Android. Until you don't have it, you wont able to use your profiles. The WP app is still under development.

    Please read the announcement at the social site main page for more detail.

    • 8 posts
    February 8, 2015 9:31 PM CET

    You will be able to get your custom designed profiles on you Sbrick app, as soon as the new update for the Sbrick app is available.

    • 3 posts
    February 8, 2015 8:16 PM CET
    Hello sbrick team

    The designer app is great but how can i get my personal profile in the profile market in the sbrick app to use it and controle my moc
    • 20 posts
    February 8, 2015 7:57 PM CET

    How would I use my custom profile? Or get to it on my iphone 5c? I used the 16:9 screen ration on the designer but can't seem to find it on the app.

    • 87 posts
    February 8, 2015 6:53 PM CET

    Just to report that I'm using Firefox 35.0.1 also but with Ubuntu 14.10 full updated and had no problems (but did only a basic profile, just 4 sliders and no background image). If you want I can try to repeat NXT45 actions to see if it also happens with me.

    • 20 posts
    February 8, 2015 6:45 PM CET

    [blockquote]Zsolt Szrapkó said:

    Dennis: It's not that simple. Sadly.

    Jens: Currently no, but it will be possible in the future.

    Jurgen: We are investigate the problems with the latest Apps. I hope we can say more tomorrow.

    NXT45 R.: We don't recommend to use the Profile Designer with Firefox (at the beta1 phase), please try with Safari, and be patient. We are going to digg down to the performance issues tomorrow.

    [/blockquote]

    Thanks!


    This post was edited by NXT45 R. at February 8, 2015 7:56 PM CET
    • 138 posts
    February 8, 2015 6:40 PM CET

    Dennis: It's not that simple. Sadly.

    Jens: Currently no, but it will be possible in the future.

    Jurgen: We are investigate the problems with the latest Apps. I hope we can say more tomorrow.

    NXT45 R.: We don't recommend to use the Profile Designer with Firefox (at the beta1 phase), please try with Safari, and be patient. We are going to digg down to the performance issues tomorrow.

     

    • 20 posts
    February 8, 2015 6:10 PM CET

    Hi I know you are working hard on the profile designer but can you kindly make it possible to save our work?

    I am using firefox 35.0.1 on Mac OS 10.10.2 & my profile is #398

    Thank you!

    NXT45


    This post was edited by NXT45 R. at February 8, 2015 6:13 PM CET
    • 23 posts
    February 8, 2015 12:44 PM CET

    As soon as I select my self-created profile in the MOC-setting page in the App, the App crashes. So I can't use it my custom profile. Even the simplest pofile with just one slider and close button does not work. The standard profiles (like the drawn one) work correctly.

    I'm using the correct ratio (16:9) as inducated by the App itself.

    Profile was created using Chrome on Win7 - 64 bit. App (v3.6.1) running on IOS 8.1.3 on iPod Touch.

    • 13 posts
    February 8, 2015 1:21 AM CET
    Hi,
    is it possible to create a flashlight with the profiledesigner? Or brakelights like in the 42030 profile?
    • 41 posts
    February 7, 2015 7:26 PM CET

    [blockquote]Zsolt Szrapkó said:

    Denis: Yes, we know about that, we are working on. However, we don't recommend to use Internet Explorer anyway. If you press the home button, and the profile is unsaved, you get this message. Can you describe me, how do you using the Designer? (how many controls, how many custom images, etc.)

    [/blockquote]

    I add 2 slider, no custom images, all default. I put different names to sliders.

    I think the problem here is the page (or server) is too slow.

    • 3 posts
    February 7, 2015 5:40 PM CET

    Hi Zsolt,

    Mr Profile is 311. I have named each channel individually.

    I dont think the custom profile is a problem becuase as i said the default market profiles have the same issue, sliders and buttons work, but joysticks dont.

     

     


    This post was edited by Tuan Nguyen at February 7, 2015 5:41 PM CET
    • 6 posts
    February 7, 2015 5:39 PM CET

    I just tried to create it with safari (via mobile) and it worked: now i can also modify it via chrome... But, if I create a 4:3 profile directly with chrome, I still cannot visualize the added controls... 


    This post was edited by sara sacchi at February 7, 2015 5:41 PM CET
    • 138 posts
    February 7, 2015 5:38 PM CET

    sara: It's strange. I will test it out on monday. Until, do you saved the profile when the controls not appeared? If that so, the Profile is saved the buttonless state, and you should try to create another one.

    • 6 posts
    February 7, 2015 5:27 PM CET

    I tried to re-load several times... nothing, the controls do not appear... and it happens only with the 4:3 ratio! Any suggestion? I'm using chrome...


    This post was edited by sara sacchi at February 7, 2015 5:27 PM CET
    • 138 posts
    February 7, 2015 5:13 PM CET

    sara: Maybe a reload can help.