Forums » Support

Back To Topics

Profile Designer

    • 184 posts
    February 10, 2015 5:39 PM CET

    ok, checking it NOW

  • February 10, 2015 5:33 PM CET
    Same problem as conor david
  • February 10, 2015 5:32 PM CET
    Yes... I' m using the right Ratio.
    Yesterday the worked... Thema Made some changes and they do not appear. I've made some others with different ratio but non worked
    • 21 posts
    February 10, 2015 5:29 PM CET

    yes.

    I haven't deleted the original profile from the Profile Designer - I just added a button.

    But profile is not visible in 'Market'

    • 184 posts
    February 10, 2015 5:22 PM CET

    [blockquote]Conor Davies said:

    Just tried to update a profile (following NXT 45 R's suggestion), but was unable to do so on my ipad mini, even though I could see the changes I had made on my computer using the Profile Designer.

    Re-installed SBrick (3.6, build 158) app via Testflight (ios 8.1.2, ipad Mini).

    usual crash after first log-in.

    re-started app.

    tried to 'add profile' - was prompted to 'Log In' - but no profiles now visible for me!

    I have Profile Designer open on my PC and can see the profile I have made (and was using until 20 minutes ago).

    On my ipad I get the message 'You haven't got custom profiles yet. use the profile designer at.......'

    So, thoroughly confused now and have taken a backwards step with my SBrick.

    Please can someone advise on what I might have done wrong?

    many thanks.

    [/blockquote]

     

    Are you using the right aspect ratio when you created the profile. As I know iPad has 4:3.

     

    • 21 posts
    February 10, 2015 5:15 PM CET

    Just tried to update a profile (following NXT 45 R's suggestion), but was unable to do so on my ipad mini, even though I could see the changes I had made on my computer using the Profile Designer.

    Re-installed SBrick (3.6, build 158) app via Testflight (ios 8.1.2, ipad Mini).

    usual crash after first log-in.

    re-started app.

    tried to 'add profile' - was prompted to 'Log In' - but no profiles now visible for me!

    I have Profile Designer open on my PC and can see the profile I have made (and was using until 20 minutes ago).

    On my ipad I get the message 'You haven't got custom profiles yet. use the profile designer at.......'

    So, thoroughly confused now and have taken a backwards step with my SBrick.

    Please can someone advise on what I might have done wrong?

    many thanks.


    This post was edited by Conor Davies at February 10, 2015 5:17 PM CET
    • 184 posts
    February 10, 2015 5:13 PM CET

    [blockquote]juerg siegenthaler said:

    hello
    Have the problem that when I add a profile, it does not turn to the Android app will appear ..
    The problem I have only been this morning ...
    Have the whole day again and again trying to solve the problem I've uninstalled the app and the profiles have deleted and recreated.
    What is going wrong ???

    [/blockquote]

     

    Are you using the right aspect ratio (that matches with your mobile device) when you creating the profile?

  • February 10, 2015 5:10 PM CET

    hello
    Have the problem that when I add a profile, it does not turn to the Android app will appear ..
    The problem I have only been this morning ...
    Have the whole day again and again trying to solve the problem I've uninstalled the app and the profiles have deleted and recreated.
    What is going wrong ???

    • 20 posts
    February 10, 2015 4:22 PM CET

    [blockquote]Conor Davies said:

    Could I please request a 'RESET' button for the Profile Designer - just like the one used for the Port Tester in the SBrick app?

    I would like to have a slider that does not auto-reset when you take your finger off it, but that can be turned OFF by use of a RESET button. This button will also reset the slider to the desired 'ZERO' position.

    I hope that, since this feature has already been programmed in to the SBrick app , this shouldn't be too difficult to transfer across to the Profile Designer...

    Could someone respond a let me know if my request is:

    a) reasonable

    b) possible

    c) likely to happen in the near future, please?

    This would allow me to set the speed of a motor and release the slider, and then switch it OFF when desired. At present it is nearly impossible to manually slide the slider to the exact position where the motor turns OFF and no signal is sent to the motor.

     

    Many thanks

    Conor

    [/blockquote]

    Hi Conor, I think that if you name a button & a slider the same (with the slider set to NOT reset) then you might be able to do this. Also set the button's to output to 0.

    • 21 posts
    February 10, 2015 4:15 PM CET

    Could I please request a 'RESET' button for the Profile Designer - just like the one used for the Port Tester in the SBrick app?

    I would like to have a slider that does not auto-reset when you take your finger off it, but that can be turned OFF by use of a RESET button. This button will also reset the slider to the desired 'ZERO' position.

    I hope that, since this feature has already been programmed in to the SBrick app , this shouldn't be too difficult to transfer across to the Profile Designer...

    Could someone respond a let me know if my request is:

    a) reasonable

    b) possible

    c) likely to happen in the near future, please?

    This would allow me to set the speed of a motor and release the slider, and then switch it OFF when desired. At present it is nearly impossible to manually slide the slider to the exact position where the motor turns OFF and no signal is sent to the motor.

     

    Many thanks

    Conor

    • 167 posts
    February 10, 2015 2:48 PM CET

    Denis, please try again, we've just deployed a new version, it should be reasonably fast.

    [blockquote]Denis H said:

    Profile designer is working, but the page is very SLOW (or the server)...i have the message time to time that the page can't load (prompt with the wait or close window)...if i click wait eventually the page load..... Once i enter in the design part i made a profile and try to save, but the orange SAVING... message stay forever...the profile don't save, because i press the "Home" button and says all my work will be lost, because is not saved.

    I'm using Google Chrome.......testing with Internet Explorer and is worst.

     

    Screenshot:

    https://social.sbrick.com/albums/photo/view/album_id/170/photo_id/585

    https://social.sbrick.com/albums/photo/view/album_id/170/photo_id/586

     

     

     

    [/blockquote]

    • 23 posts
    February 10, 2015 12:54 PM CET

    Sorry for the double post:

    Update:

    I created a fancy profile for my excavators and successfully loaded into my IOS app. The profile includes joysticks, sliders, light-buttons and a custom-created background.

    Now there's only only one thing that sets this profile apart from being perfect: the invert-buttons for the output-ports in the App don't work. In the profile designer you can invert a slider with the Value-setting, but not for the joysticks. So either the profile-designer must be updates with an inverting-functions for the joysticks or the invert-switches in the SBrick-output-assignment screen should be fixed. Preferably both of course.

    I'm using Chrome, IOS 8.1.3, iPod touch and app version 3.6.1 (176)

    • 23 posts
    February 10, 2015 9:30 AM CET

    After your latest update of desigher.sbrick.com I successfully added my custom profile to my Moc in the App. Thanks !!!  8-)

    Now I can continue testing the profile designer and hopefully finally create the new profile for my Link Belt and U-8043S excavators.


    This post was edited by Jurgen Krooshoop at February 10, 2015 9:31 AM CET
    • 142 posts
    February 10, 2015 9:12 AM CET

    Hi guys, we are planning a huge performance update today. :)

    If everything goes well (we still need to run tests), you don't need wait to save your profile for lot of seconds anymore, except the first loading, when the Profile Designer convert your profile into a more bandwith friendly version. Thanks for your patient. :)

    • 57 posts
    February 10, 2015 3:03 AM CET

    Your instinct was absolutely correct Conor! :)

    It is a pitty there is no threshold or hysteresis setting.

     

    Meanwhile I proceed testing PD with iOS app (iPhone 5), and it is now working pretty well! :)

    - My 16:9 profiles load and work.

    - Rotated joysticks appear and work straight instead of their settings.
      It is not yet this time that I'll test a treaded vehicle specific profile. ;)
      Rotated sliders are fine though!

    - Both on Chrome and FF, numeric settings like control rotation, does not accept numbers. One must relly on mouse rotation which is not 100% accurate. For instance I want 45º and always get 44º or 46º...

     

    On my Android device (Galaxy Note PRO 12.2) it always displays 16:9 profiles only, while this device is has a 16:10 aspect ratio. :P


    This post was edited by Fernando Correia at February 10, 2015 3:07 AM CET
    • 21 posts
    February 9, 2015 9:55 PM CET

    Thanks for the suggestions, Fernando.

    I shall try them tomorrow.

    My instinct tells me that 'Start Point' is where the slider is first positioned when you use the profile, and 'Zero Point' is the position that gives 'zero' output (i.e. 'OFF').

    I think that there is no 'dead zone' at the Zero Point, so I really need a 'Reset' button - just like the one used in the Port Tester. (So, there must already be two control functions that control the same port in the Port Tester. One is a slider and the other is the 'Reset' button)

    Is it possible to provide the same 'Reset' button in the Profile Designer, please? You have already made them for the Port Tester, so can they be made available in the Profile Designer?

     

    Thanks in advance.

     

    Conor

    • 57 posts
    February 9, 2015 7:34 PM CET

    Hmm... sorry for the double post!

    I think the "zero point" might be a zero offset in the control (it means zero would be shifted from the center, for whatever the reason you migh need this.

    The "start point" might do the trick, but still unclear for me how it will work in conjuntion with the offset definition. :/

    • 57 posts
    February 9, 2015 7:31 PM CET

    While what you're requesting makes sense, it seems to go against the SBrick Profiles software architecture, where you a different funtion defined for each virtual control object.

    I had not yet the chance to try it, but I think that what you are trying to achive can be set with the "zero point" and "start point" definitions in the slider control.

    Although and as I did not try it yet, I'm not figuring out the meaning of both. My intuition tells me that just one would be enough. Basically it would set spacial threshold out of which the the slider starts powering the port assigned. Within that threshold area the output would remain with zero power.

    The humming noise you hear is because of your settings and finger "resolution" you can hardly set it to zero, and you will never know the actual value. The threshold definition might solve your problem.

    You just need to play a bit with the values to find their real meaning, what I'll do also. :)

    • 21 posts
    February 9, 2015 7:17 PM CET

    Thanks, NXT45R.

    I have no idea why I cannot add a background picture from within SBRICK app - nobody has yet suggested why this bug exists.

    As for the Auto-Reset...

    I don't want the slider to automatically return to the centre position because I want to be able to leave the motor running at whatever speed I choose. I do, however, want to be able to turn the motor 'OFF'. Using the slider does not actually turn the motor OFF, it just stops turning but it still receives a signal (and makes a horrible noise!).

    What I'd like is a RESET button, like in the Port Tester, which will turn OFF the motor completely (and, in an ideal world, reset the slider to zero).

     

    Other issues:

    SBRICK app always crashes and shuts down on first log-in. Re-opening the app brings trhe app back (logged in). Will TESTFLIGHT pick all these things up automatically?

     

    Thanks in advance for any guidance.

    Conor

     

     

    • 20 posts
    February 9, 2015 5:34 PM CET

    Hi guys, sorry for the double post but here are some photos I found. You can use them in the PD for light on & off. https://social.sbrick.com/albums/view/203

    • 20 posts
    February 9, 2015 3:51 PM CET

    [blockquote]Conor Davies said:

    Hi,

    just updated (via TestFlight, Ipad mini, ios 8.1.2) and have just uploaded my simple profile.

    Two issues:

    1. Still cannot select background image. I get offered 'Camera' and 'Photo library', but selecting either of these does not take me to camera or photo library. The menu for the choices simply disappears.

    2. Is there a 'reset' button available in Profile Designer, like in the port tester, please? I have a simple slider that does not 'Auto reset' (so you can take finger off ipad and motor still runs) but would like motor to turn off 'properly' when required. Sliding the slider to the middle doesn't actually turn off the motor - it just makes a whining noise without turning.

    Many thanks so far for the Profile Designer.

    [/blockquote]

    Hi Conor, here is how you can fix the problem you are having. 

    Problem Solved

    [blockquote]Peter Subert said:

    Hi Developer team,

    I tried to use the profile designer, with no success running it on w7 and Chrome, ratio irrelevant:-(.

    1. The visualization panel shows a black screen only, even if I picked any controls, they are invisible.

    2. Saving the profile was not successful at all. "Saving..." message was displayed for 10+ minutes, where I gave up:-(. Nothing was saved at the end.

    Please advise, what browsers and what devices are supported.

    However, Victory is declared: I could create my first profile using my iPad2:-).!! A few questions came up during the design:

    1. It would be great to sort objects by type in the layer view.
    2. It would be good to know, how a slider can be rotated with 90 degrees to set it horizontal looking.
    3. It would be good to add some basic graphics: e.g. colored fonts and rectangles (round, straight?), that can make it a bit more attractive and practical to group and separate controls.
    4. How can we add new graphical object styles for buttons, joystick or sliders? What are the technical requirements to include them in the library?
    Also, please let me know, how can I download the new profile to my SBrick app on my IOS devices?

    When will you publish the User Guide for the profile designer, please?

     

    P.S. How can I add screenshots to the threads? I had no such option working with FF OR Chrome on my laptop (it works fine on the iPad2 though).

    Nevertheless, it is a good start, congratulations to the whole team! Keep up with the good job!

    Cheers,

    Peter

    [/blockquote]

    Hi Peter, I don't know how to fix the first problem but here is how you fix #2.


    This post was edited by NXT45 R. at February 9, 2015 4:05 PM CET
    • 21 posts
    February 9, 2015 1:39 PM CET

    Hi,

    just updated (via TestFlight, Ipad mini, ios 8.1.2) and have just uploaded my simple profile.

    Two issues:

    1. Still cannot select background image. I get offered 'Camera' and 'Photo library', but selecting either of these does not take me to camera or photo library. The menu for the choices simply disappears.

    2. Is there a 'reset' button available in Profile Designer, like in the port tester, please? I have a simple slider that does not 'Auto reset' (so you can take finger off ipad and motor still runs) but would like motor to turn off 'properly' when required. Sliding the slider to the middle doesn't actually turn off the motor - it just makes a whining noise without turning.

     

    Many thanks so far for the Profile Designer.

     

     

    • 142 posts
    February 9, 2015 1:33 PM CET

    Hi guys. We just pushed out a new release which is fixed some bugs:

    - If your profile is freezed out the SBrick app, you should update it in the Market, we fixed it.
    - We also fixed the Problem when the controls not showed up on some aspect ratio.
    - At the start screen, you can see a "Downloads & Extras" section where you can download all the default resource files and a sample PSD.

    Fernando: I looking after this problem, Lenard also reported this behavior, but I can't reproduce it.

    Peter: Thanks for the kind words. :) We are in hard work to optimize how the Designer handling the Profiles data. I hope it will be more stable, and more responsive in this week. The User Guide is also coming soon.

    Jakob: Thanks for that link! ;)

  • February 9, 2015 9:59 AM CET

    In case you don't know your screen aspect ration:

     

    http://www.iosres.com

    • 33 posts
    February 9, 2015 4:50 AM CET

    Hi Developer team,

    I tried to use the profile designer, with no success running it on w7 and Chrome, ratio irrelevant:-(.

    1. The visualization panel shows a black screen only, even if I picked any controls, they are invisible.

    2. Saving the profile was not successful at all. "Saving..." message was displayed for 10+ minutes, where I gave up:-(. Nothing was saved at the end.

    Please advise, what browsers and what devices are supported.

    However, Victory is declared: I could create my first profile using my iPad2:-).!! A few questions came up during the design:

    • 1. It would be great to sort objects by type in the layer view.
    • 2. It would be good to know, how a slider can be rotated with 90 degrees to set it horizontal looking.
    • 3. It would be good to add some basic graphics: e.g. colored fonts and rectangles (round, straight?), that can make it a bit more attractive and practical to group and separate controls.
    • 4. How can we add new graphical object styles for buttons, joystick or sliders? What are the technical requirements to include them in the library?
    Also, please let me know, how can I download the new profile to my SBrick app on my IOS devices?

    When will you publish the User Guide for the profile designer, please?

     

    P.S. How can I add screenshots to the threads? I had no such option working with FF OR Chrome on my laptop (it works fine on the iPad2 though).

    Nevertheless, it is a good start, congratulations to the whole team! Keep up with the good job!

    Cheers,

    Peter


    This post was edited by Peter Subert at February 9, 2015 8:03 AM CET