Forums » Support

Back To Topics

Profile Designer

    • 143 posts
    October 22, 2016 2:33 PM CEST

    Profile Designer 1.2.1 is released!

    Release notes:

    - New element in the controls list: images. You can add custom images to your profile.

    - Redesigned settings panel for controls, now you can find everything within one page.

    - New settings for the Sequence channels: now you can set up what happens with the output, when the sequence finished.

    - The Joystick control now has a minimum / maximum value pair for the X and the Y coordinate too.

    - The Quickstart Guide is gone, you can access to the Manual when you click on the "?" icon in the header. It's also available on the start page.

    - Bugfixes and minor improvements


    This post was edited by Zsolt Szrapkó at October 22, 2016 2:34 PM CEST
    • 4 posts
    August 21, 2016 1:13 PM CEST

    [blockquote]Alex McQuilkin said: Hello Poi You have to make an image of what you want the layout to be in a drawing program the same size as the screen size of the control device. Save as a .png or .jpg Go into profile designer and look for resources. Find the background tab and load in your created jpg. Then in your profile load your created background in and shuffle the controls to match your back ground. Hope this helps Alex[/blockquote]

    Thanks Alex, yes it works fine! Many thanks for your help. :-)

    • 17 posts
    August 21, 2016 12:04 AM CEST
    Hello Poi
    You have to make an image of what you want the layout to be in a drawing program the same size as the screen size of the control device. Save as a .png or .jpg Go into profile designer and look for resources. Find the background tab and load in your created jpg. Then in your profile load your created background in and shuffle the controls to match your back ground.

    Hope this helps
    Alex
    • 4 posts
    August 20, 2016 8:03 PM CEST

    Hello everybody,

    Can someone tell me how to create a description at the switches in my profile?

    Many thanks!

    • 143 posts
    August 11, 2016 4:17 PM CEST

    [blockquote]Jörg Bachmayr said:

    Thx for the info!

     

    A short hint from a progammer: if you implement an import and export function for xml file format, many possibilities would be available ;)

    best regards

    jm

    [/blockquote]

    Your request has nothing to do with the file format, we just currently working on bigger features. :)

    But like Balint's said, this feature is on our list.

    • 5 posts
    August 11, 2016 3:41 PM CEST

    Thx for the info!

     

    A short hint from a progammer: if you implement an import and export function for xml file format, many possibilities would be available ;)

    best regards

    jm

    • 310 posts
    August 11, 2016 3:34 PM CEST

    [blockquote]Jörg Bachmayr said:

    Question: is there a way to change the ration of an existing profile?

    I have a profile with the ration 16:9 and want to "copy" this profile to a 16:10 ratio ... is there a way?

     

    Thx in advance!

    [/blockquote]

     

    Hello! 

     

    Unfortunately, this function is not available. :(

    So, you have to creat a new one with the convenient screen ratio. 

    We are planning to make it in the future, but it it takes us time yet. 

     

    Regards, 

    Balint - SBrick Team 

     

     


    This post was edited by Balint Mezei at August 11, 2016 3:36 PM CEST
    • 5 posts
    August 11, 2016 11:28 AM CEST

    Question: is there a way to change the ration of an existing profile?

    I have a profile with the ration 16:9 and want to "copy" this profile to a 16:10 ratio ... is there a way?

     

    Thx in advance!

    • 164 posts
    August 1, 2016 3:56 PM CEST

    Hello Klaus,

    First of all, you need to add a button to the profil.
    You can set the button's output vaule to 0. If you use the button and the slider with the same chanell name, the slider will switch to zero when you touch the button.

    If you need more help just let me know.

    Tamas. 


    • 7 posts
    July 31, 2016 7:13 PM CEST

    Hello Team

    if the profile designers a slider is not programmed to auto reset and the slide will stop in any position . How can I switch the slider manuel to zero . Can a button the all Slider and Button are programmed reset to zero itself .

     

    Gruß Klaus

    • 11 posts
    July 27, 2016 3:35 PM CEST

    Hey,

    I just saw a video on YT (https://www.youtube.com/watch?v=Y9h49WccF5c) were somebody controlled first every motor with one slider each. Then he controled all motors with one sequence button together. I tried to do the same, but I just can control every SBrick Port by one Button or Slider. (iOS App) So I have to decide, controlling with sliders or sequence button. 

    For me its not possible to build trafficators and hazard flashrs with just to pairs of LEGO LEDs; I would need 4 pairs...

     

    Thanks!

    • 143 posts
    July 27, 2016 11:05 AM CEST

    [blockquote]Gerard Hogenhout said:

    [blockquote]Zsolt Szrapkó said:

    [blockquote]Gerard Hogenhout said:

    I have a big problem regarding the profile designer. I can add a slider but not change any settings at all on the left! This seems like a software bug as on older projects, there were sliders on which I can adjust the settings.

    Please please can you solve this issue before the wheather gets bad again?

    --edit: look how many of these similar complaints are appearing on this forum!! Guys fix it or you will make a lot of people angry!!

    (I have tested this on Chrome AND the last version of Mozilla Firefox both... NOT WORKING!!)

    [/blockquote]

    [blockquote]Heiko Mueller-Meissner said:

    Same problem! Tested with Chrome, Firefox, Edge using Windows 10 Pro 64-bit. GUI-Elements are not editable. No Layer submenu.

    [/blockquote]

    Hi there,

    Sadly, I can't reproduce your problem, but i want. Please provide me the affected profile's ID to fix this ASAP.

    [/blockquote]

    Where can I find my profiles' ID on this website?

    [/blockquote]

    It's in the browser's url bar, like https://designer.sbrick.com/index.php?profile=12345

    In
    this example the 12345 is the ID.

  • July 27, 2016 8:13 AM CEST

    Hello Zsolt,

    after clearing Chrome's cache, Designer 1.1.1 is now working fine for me.

    Thank you and have a nice day.

    • 17 posts
    July 27, 2016 5:22 AM CEST

    Hello Zsolf

    I followed the recent message exchanges regarding Profile Designer and just finished testing with Chrome 51.0.2704.106 64 bit on profiles 11941, 11876, 11846 and 8491  the sliders work but the Points and Values and there variable ajustmensts dont show up in the menu for Joysticks but they must be there because the joysticks work correctly when the profile is added and the bricks are assigned in the OS version 4.1 on my iPhone 6+ my iPad Air and my iPad Pro  The first two are on OS 9.3.3 and the pro is on a beta of OS 10

    Thanks for the work I haope this helps track the error.

    Cheers

    Alex

  • July 27, 2016 2:40 AM CEST

    [blockquote]Zsolt Szrapkó said:

    [blockquote]Gerard Hogenhout said:

    I have a big problem regarding the profile designer. I can add a slider but not change any settings at all on the left! This seems like a software bug as on older projects, there were sliders on which I can adjust the settings.

    Please please can you solve this issue before the wheather gets bad again?

    --edit: look how many of these similar complaints are appearing on this forum!! Guys fix it or you will make a lot of people angry!!

    (I have tested this on Chrome AND the last version of Mozilla Firefox both... NOT WORKING!!)

    [/blockquote]

    [blockquote]Heiko Mueller-Meissner said:

    Same problem! Tested with Chrome, Firefox, Edge using Windows 10 Pro 64-bit. GUI-Elements are not editable. No Layer submenu.

    [/blockquote]

    Hi there,

    Sadly, I can't reproduce your problem, but i want. Please provide me the affected profile's ID to fix this ASAP.

    [/blockquote]

    Where can I find my profiles' ID on this website?


    This post was edited by Gerard Hogenhout at July 27, 2016 2:41 AM CEST
  • July 27, 2016 2:37 AM CEST

    [blockquote]Balint Mezei said:

    [blockquote]Gerard Hogenhout said:

    I have a big problem regarding the profile designer. I can add a slider but not change any settings at all on the left! This seems like a software bug as on older projects, there were sliders on which I can adjust the settings.

    Please please can you solve this issue before the wheather gets bad again? 

    --edit: look how many of these similar complaints are appearing on this forum!! Guys fix it or you will make a lot of people angry!!

    (I have tested this on Chrome AND the last version of Mozilla Firefox both... NOT WORKING!!)

    [/blockquote]

    Hello Gerard! 

    What OS do you use? 

    Regards, 
    Balint 
    SBrick Team

    [/blockquote]

    Windows 10 64 bit

    • 143 posts
    July 27, 2016 1:40 AM CEST

    [blockquote]Gerard Hogenhout said:

    I have a big problem regarding the profile designer. I can add a slider but not change any settings at all on the left! This seems like a software bug as on older projects, there were sliders on which I can adjust the settings.

    Please please can you solve this issue before the wheather gets bad again?

    --edit: look how many of these similar complaints are appearing on this forum!! Guys fix it or you will make a lot of people angry!!

    (I have tested this on Chrome AND the last version of Mozilla Firefox both... NOT WORKING!!)

    [/blockquote]

    [blockquote]Heiko Mueller-Meissner said:

    Same problem! Tested with Chrome, Firefox, Edge using Windows 10 Pro 64-bit. GUI-Elements are not editable. No Layer submenu.

    [/blockquote]

    Hi there,

    Sadly, I can't reproduce your problem, but i want. Please provide me the affected profile's ID to fix this ASAP.


    This post was edited by Zsolt Szrapkó at July 27, 2016 1:42 AM CEST
    • 143 posts
    July 27, 2016 1:40 AM CEST

    I just released an update, i hope it solves some of the problems.

    On the close button: we had a bug before that caused the close button is always moved a little after saving (wrong coordinate calculations). Now if you move it to the place, it must stay there. 

    There was also an error with the buttons (simple button, clinometer, sequence) on profiles created before 1.1.0. It's fixed now.

    • 143 posts
    July 26, 2016 11:31 PM CEST

    We're investigating the issues right now.

  • July 26, 2016 6:21 PM CEST

    Same problem! Tested with Chrome, Firefox, Edge using Windows 10 Pro 64-bit. GUI-Elements are not editable. No Layer submenu. 

    • 310 posts
    July 26, 2016 5:06 PM CEST

    [blockquote]Gerard Hogenhout said:

    I have a big problem regarding the profile designer. I can add a slider but not change any settings at all on the left! This seems like a software bug as on older projects, there were sliders on which I can adjust the settings.

    Please please can you solve this issue before the wheather gets bad again? 

    --edit: look how many of these similar complaints are appearing on this forum!! Guys fix it or you will make a lot of people angry!!

    (I have tested this on Chrome AND the last version of Mozilla Firefox both... NOT WORKING!!)

    [/blockquote]

    Hello Gerard! 

    What OS do you use? 

    Regards, 
    Balint 
    SBrick Team

  • July 25, 2016 7:11 PM CEST

    I have a big problem regarding the profile designer. I can add a slider but not change any settings at all on the left! This seems like a software bug as on older projects, there were sliders on which I can adjust the settings.

    Please please can you solve this issue before the wheather gets bad again? 

    --edit: look how many of these similar complaints are appearing on this forum!! Guys fix it or you will make a lot of people angry!!

    (I have tested this on Chrome AND the last version of Mozilla Firefox both... NOT WORKING!!)


    This post was edited by Gerard Hogenhout at July 25, 2016 7:13 PM CEST
    • 17 posts
    July 20, 2016 6:12 PM CEST

    Hello

    I am still having a problem with profile designer being able to add or edit joystick controls on existing or new profiles.  in the setup menu both the Points and Values titles and input method are missing from the menu.  I have tried Firefox Safarie and Chrome on my MacBook Pro with 10.9.5. Any Ideas about a fix?

    Thanks Alex

    • 143 posts
    July 20, 2016 5:34 PM CEST

    [blockquote]Jens Heyer said: [blockquote]Zsolt Szrapkó said:

    I can't reproduce this one. I tested it in Safari and Chrome too. Can you tell me which browser do you use?

    [/blockquote] I use Chrome. It's in profile 852. I created an own picture for the sequence button. It's not square but rectangular. What do you mean with "manually brake lights "? I have to push manually a button for lights on? That's no option! [/blockquote]

    On the button: I will check this.
    On the break lights: We're working on a solution, but there's no exact ETA for this. I hope we will be done in the august-september period.

     

    • 13 posts
    July 19, 2016 11:04 PM CEST
    [blockquote]Zsolt Szrapkó said:

    I can't reproduce this one. I tested it in Safari and Chrome too. Can you tell me which browser do you use?

    [/blockquote] I use Chrome. It's in profile 852. I created an own picture for the sequence button. It's not square but rectangular. What do you mean with "manually brake lights "? I have to push manually a button for lights on? That's no option!