Forums » Support

Back To Topics

SBrick Android App

  • December 30, 2014 11:22 PM CET

    A profile type for 42030 (or other officials models) exist in market?

    • 25 posts
    December 30, 2014 6:18 PM CET



    I went with further tests.

    Test1 profile is ok, but button does not switch off the lights (light turns on, but when switching off the button, displays shows it off, but light are still on). Interresting point is that it's possible to have all range of lighting with a slider, not just on/off !!! That opens possibilities! Note: sometimes, when releasing the slider, it comes to center, but the motor is still working.

    One useful thing would be to have a reminder on the profile's displays with which slider is "slider 1", which is "slider 2", etc. (idem with buttons). That would help a little bit (even maybe add to which port it's linked!).

    Profiles which uses gyro are not really working well with my phone (Samsung Galaxy Note 2). Impossible to get them work correctly (zero or full speed, direction not taken in account, etc.).

    Joystick or gamepad 1 (display pb - the joystick stick does not appears) not working either. Gamepad 2 also have pb, impossible to get it work, and displays seems to be corrupted/distorded.


    Interresting point: when having a pb with a profile, go to market, delete profile, then redownload it and it works better! (does not work with joystick or gamepad 1 for me - sometimes app crashes when deleting the profile in the set edition)

    I know it's still under development, it's just to give you a feedback :-)

    See you later... (and warn me if you need a test :-) )


    • 1 posts
    December 30, 2014 10:52 AM CET

    Hi Everybody!

    I can't pairing my phone with SBrick. I have Sony XPeria SP, Android 4.3, BLE Checker say BLE Supported. nRF Master Control Panel can connect, without previosly pairing. SBrick LED blink shortly after switching power on. I tried it with AA batteries (8881) and rechargeable battery box (8878). My phone bluetooth settings found the SBrick, but can't pairing. I have the latest SBrick Android App version 0.0.21 and this can't discover SBrick. Please help!

    This post was edited by Zsolt Pogonyi at December 30, 2014 1:27 PM CET
    • 25 posts
    December 30, 2014 9:22 AM CET



    Just a suggestion: as there is more and more profiles, it's becoming a little bit hard to remember which one have sliders, or steering whell, or light switches.

    So it would be very nice that, when selecting the profile, we could have a little image of the controlers, just to quickly see which profile it is really in terms of controlers.


    And as previously asked, inverters for each port would be very nice to have.


    Thank you :-)



    This post was edited by Sylvain CACHEUX at December 30, 2014 9:22 AM CET
    • 10 posts
    December 30, 2014 1:59 AM CET

    [blockquote]Maxim Baybakov said:At least we have three people with a problem "discovering sbrick..." using Galaxy S3. I hope we will not stay without attention![/blockquote]

    Make that 4...

    • 17 posts
    December 30, 2014 1:34 AM CET

    They should put the profile for the 42030 up on Market if it works. At least people could do something with it.

    • 4 posts
    December 29, 2014 11:20 PM CET

    [blockquote]Sylvain CACHEUX said:

    Edit: I uninstalled the app, reinstalled, redownload the market, recreate a new moc profile, and this time it worked! I do not know what changed, I guess the cache has been reset.


    Same here, Android app crashes and you can't save an sbrick in a moc until you uninstall and re-install.

    As mentioned elsewhere the brick makes a high pitch whine when operating, and there's no obvious way to reverse inputs it seems. Also noticed that sometimes on 'releasing' a slider the motor not stop, and you have to tap in the middle position when the control already is to stop or centre.

    All that, given it's in Beta and I've got it working within an hour I'm quite happy :-) Just have to remember down is forward, and up backwards...


    • 34 posts
    December 29, 2014 10:34 PM CET

    Which profile did you use ?

    No problems with reversing inputs ?

    • 2 posts
    December 29, 2014 10:32 PM CET

    Just tested one of my Sbricks for the first time. First time right! Love it. Using Sbrick 0.21 on a Samsung S5 mini. Ultimate control, 4 slider controle, over the 42030.

    The only thing I notice; it creates a very high pitched sound when active. Is that normal?

    This post was edited by Michel Scheffer at December 29, 2014 10:33 PM CET
  • December 29, 2014 8:35 PM CET

    It's good. I buy a Samsung Galaxy Pocket 2 (SM-G110H) in 4.4.2 Android version and V4.0 Bluthoot. I DL apps in first time. It's OK for sinchronise a smartphone and SBrick. But don't find a commands for my 42030. I make it?

    • 17 posts
    December 29, 2014 8:12 PM CET

    Okay, has anyone manage to get any profile to work on a Galaxy S4? I removed them and downloaded the current set (Including Test 1 & Test 2 now.) None of them do diddly squat.

    The bit which amazes me is the ports work perfectly via the Manage Brick test interface. Just create a section of the interface in the APP where we have better access to those 4 sliders. At least then people can do some stuff.


    Another thing I have noticed, is that you can't delete the sets you have created under My Sets. I removed the profiles from each one, then tried to remove the Sets themselves. Nothing. Delete icon does nothing. So be careful not to create to many Sets.


    Just imagine if the SBrick has been shipped out at the original release date :)


    I don't mind the release of the SBrick before it is really ready, just because the Test ports part of the App shows you what it will eventually be capable of. Just gotta sit tight a while.

    • 24 posts
    December 29, 2014 12:23 PM CET

    Thanks to Tamas for publishing the communications protocol in the forum Suggestions.

    Using this information together with the utility nRF Master Control Panel I have been able to control my Sbricks.  This shows that there aren't any significant problems with the Sbrick itself, it is just major problems with the Android app.


    • 24 posts
    December 28, 2014 7:05 PM CET

    Uninstalled Sbrick app and installed new version from Playstore, version 21, on to my Samsung Galaxy S3 running Android 4.3.

    Changes?  None in performance that I can see!!  Still can't add a set only a MoC.  Still can't discover any Sbrick!  Only change that I can see is the version number!

    • 10 posts
    December 28, 2014 4:00 PM CET

    [blockquote]Toku Betsu said:

    My SBrick app updated last night. Was previously on 0.0.20 and is now 0.0.21. Apparently a scan fix has been done.

    [/blockquote]"Apparently" yes, because I see no changes on my LG G2. SBrick visible in Bluetooth menu of the phone, but SBrick App can't find it.


    Also the LED doesn't go on, it just flashes for a fraction of a second when you turn on the power. Not sure if this is normal behavior?

    This post was edited by Nick Matthews at December 28, 2014 4:06 PM CET
    • 4 posts
    December 28, 2014 3:43 PM CET

    Yesterday I resived my SBrick.

    After powering on the SBrick the manual says the LED should turn on. I did not... I though is my SBRick broken.

    But after 2 times re-installing the App my Samsung S5 I was able to operate the SBrick.

    I found that the LED is working if your turn it on in the Manage Brick menu (identify led).

    I installed the SBrick on my 41999 and only profile Gamepad 2 was working, except the speed control was working reverse.

    I don't know who to reverse the output controls.

    The Joystick does not work at all and the steering profiles do not react very well.

    Gamepad 1 does not work at all, sometimes the app stoppes. Test 2 only shows 1 slider. So I probably have to re-install the app again..

    I also installed the SBrick app on our IPAD (software 6.1.3.) and IPOD but both cannot find the SBrick....


    I hope the software bug will be fix sone

    • 25 posts
    December 28, 2014 3:27 PM CET

    Hello everybody,


    I'm running the app version 0.0.21, on Samsung Galaxy Note II, version android 4.4.2.

    The market is ok, I managed to download all profiles.

    With the Sbrick manage bricks, I find a sbrick, the identify led works (I noticed that last time I tested, the 2 first on/off, it did not worked, then the 3rd time it worked), the port tester works with all ports, and the OTA (???) indicates that the function will be available soon.

    When I select the home page in the menu, it just displays a welcome message. When taping on it, it displays a kind of controler (joystick, black screen with white border, ...) but nothing happens on Sbrick.

    When I select "my set", I tap the "+" and create a new profile via the "add new moc button (no possibility to add an existing lego model). This adds a profile. When taping on it, I can rename it, then change its image. I can also find my sbrick (discover is a bit long). Then I tap on the Sbrick to set the ports, which works. I tap "save your set!" button and ... it crashes. Impossible to save. If I tap on the profile before, it opens the profile screen (with buttons, sliders, etc.) but it warns me that "couldn't discover all bricks!" with cancel and retry button. Retry redisplays the same message, and cancel let me on the profile, which is obviously not working.

    I tried to change the port on my Sbrick, but same error, the app is crashing, returning to my phone screen when saving my set. I manage to change the profile, and go into the sbrick ports, but always crashing when saving.


    Edit: I uninstalled the app, reinstalled, redownload the market, recreate a new moc profile, and this time it worked! I do not know what changed, I guess the cache has been reset.

    It may be helpful for others, that's why I'm posting :-)


    So that's all I can test for the moment...


    I guess you guys take some rests with your families during the holidays, after all the work you did with the hardware part, and think the app will be improved in january!


    Best regards,


    This post was edited by Sylvain CACHEUX at December 28, 2014 3:32 PM CET
    • 17 posts
    December 28, 2014 3:12 PM CET

    My SBrick app updated last night. Was previously on 0.0.20 and is now 0.0.21. Apparently a scan fix has been done.

    • 340 posts
    December 28, 2014 12:53 PM CET

    [blockquote]Charles Di Caro-Debizet said:

    My Smartphone is too old.

    Is it possible to use an application on Windows 8.1 ?



    We are working the app for WP 8.1. We will release it in January.

  • December 28, 2014 8:19 AM CET

    My Smartphone is too old.

    Is it possible to use an application on Windows 8.1 ?

    • 9 posts
    December 28, 2014 12:09 AM CET

    Hi, finally I managed to test my SBrick on other phones, since I can't get mine to work:

    It bonded perfectly with my friend XPERIA M running on 4.4.2 Android and the app worked fine. I thanked my friend and tried to clean her phone since she won't be needing neither the app nor the BLE bond with the SBrick - no problems there. But then I tried to re-bond the SBrick to her phone and it wasn't possible anymore! The phone displayed a message that went something like this: "The phone can't connect to SBrick because of the wrong PIN number or wrong password"

    I guess the same happened on my phone (XPERIA SP, Android 4.3) and my tablet (LG G-pad 8.3, Android 4.4.2) - at first I could connect the with the SBrick just fine, but when the app wasn't working at all I disconected the device in order to try a clean start - then the phone and the tablet couldn't be connected anymore - also the message like on my friends phone doen't appear.

    Is it possible, that when I disconected the SBrick form my phone (the only option is to tap "disaple connection with SBrick) that it was actually a lock for that connection and now it won't connect anymore?

    How do I reverse that and is it even possible without beeing an Adroid programmer???

    Thanks for you help,

    best regards, miha

    • 10 posts
    December 27, 2014 8:50 PM CET

    Nordic nRF Master Control Panel is a fantastic piece of software. Unfortunately SBrick-App still doesn't discover my SBrick (Nordic does).

    In the meantime SBrick on my LG G2 didn't start anymore. It just closes one second after starting without any feedback. Had to reset my phone, as deleting all data and cache and force closing the app didn't do anything.

    So... still no luck on my LG G2, I ran a few tests on a Moto G and a Galaxy Note 3 though:

    • SBrick was discovered, but Led didn't turn on in the testpanel and the testsliders didn't do anything. I've tried it about ten times before it started working. I gave up with the Galaxy Note 3, it just wouldn't do anything, even though the SBrick was found. Note that Bluetooth was either disabled on the Moto G or the Note 3 to prevent intermission.
    • Eventually when I got a profile to work on the Moto G I could confirm the Gyro is flaky and worked on the wrong axis. Unusable.
    • After playing around with a few controls the responsetime seemed to improve.
    • After a short while the controls just stopped working, I might have been messing around with different profiles too much.
    • Controls can't be reversed, or it isn't clear where this should happen, the on/off switches in the brick view don't seem to do anything (on/off wouldn't be a logical description anyway)
    • There's no feedback from the App whether or not you're connected to an SBrick. The profile just fires up and controls either work or not. There should be a way to see that you're connected and everything should work.

    (some old comment about APIs)

    I'm considering diving into an Android App myself, but my guess is I don't have time for that in the next 4 months, as I have many higher prio-activities next to my regular workweek.

    EDIT - Actually, I might as well have a look so I requested membership for development. I want this damn thing to be big success, so anything I can help with is a good thing.

    This post was edited by Nick Matthews at December 27, 2014 9:35 PM CET
    • 21 posts
    December 27, 2014 8:18 PM CET

    [blockquote]Norman Chalcraft said:In order to check the visibility of an SBrick I have installed the utility Nordic nRF Master Control Panel.  Using this  can discover an SBrick, connect to it and even Bond with it.[/blockquote]

    Thank you for program! Now I saw my bricks :)
    At least we have three people with a problem "discovering sbrick..." using Galaxy S3. I hope we will not stay without attention!

    This post was edited by Maxim Baybakov at December 27, 2014 8:19 PM CET
    • 34 posts
    December 27, 2014 4:06 PM CET

    Check it on your PC when logged in to play store

    Does it list yor devices as compatible ?

    And per info written here it does not support your version (only 4.3+ ) because of Bluetooth profile support

  • December 27, 2014 3:57 PM CET

    I have Android 4.1.2 and Idon't even see the application in the store.

    Is it possible to work with Windows 8.1 ?

    • 34 posts
    December 27, 2014 3:07 PM CET

    After another round of tests.

    - linking and unliking profiles is a sure way how to crash the app, after two - three times it is a sure thing

    - also playing with the profiles, port testing, assignment of functions, etc leaves the app in a state that it won't controll the SBrick althoug it is discovered. There are different level of disconnect - sometimes the port test works but profiles don't, sometimes after jumping the screen back an forth it starts working (not on first try), sometimes not event the port testing and LED light respond and restart of app and SBrick is needed

    - sometimes I cannot choose anything from the menu - restart app

    - here is my take on profiles as l

    1. Steering wheel 1 - gyro is totally random, not usable
    2. Steering wheel 2 - see above
    3. Test 1 - displays a metal background - no controlls
    4. Test 2 - displays random number of sliders - the ones that are displayed can be added to Sbrick and work
    5. Joystick - not working - haven't found a controll to be added that it would respond to, as it would be gyro controlled anyways, see #1/2 
    6. Gamepad 1 - not working seems to display 3 controlls over each other
    7. Gamepad 2 - the one and only working for me - except that I can revers the acceleration; one can easily lose the focus as the max deviation is too close to the edge of screen and the detection is sensitive (4.7" on HTC)

    - Still haven't found a way to invert controls, tried the switches in the SBrick controll setup, but does not work for acceleration, steering nor sliders

    I also found some (.json) files in the storage and tried editing those. But it does not seem to take effect, even when changing a single digit in one slider position. Other than that the descriptive language does not seem to be difficult, I'd suggest to release the option to hand edit the profiles for those who like to experiment. And describe some of the values and references. 

    I have the feeling that the HW received a good chunk of development, but the SW at least the Android one, is utterly lacking.

    If you have problems in catching up, please go opensource ! Somebody else will...