Forums » Support

Back To Topics

SBrick Android App

    • 198 posts
    December 22, 2014 1:03 AM CET

    We are pushed the next alpha version from the app. You can download the v0.19 from the Google Play.

    • 95 posts
    December 21, 2014 4:19 PM CET

    Like Christian says the app need a search function.

     

    Regards,

     

    Frederic


    This post was edited by Frederic Ayrault at December 21, 2014 4:21 PM CET
  • December 14, 2014 11:24 AM CET

    From my first trials with the Android app, the "add Set" function is FUBAR. It starts with a bunch of sets from 1965, and once you found that you have to choose the year from the top right menu, you get a fat selection of all sets in 2014: Duplo, Friends, Valentine promotion, whatever. Somewhere in this armlong list there are the five or six sets that might make sense to use with an SBrick application. You can't search by set number, and you are drowned in an ocoean of sets that even with a mother lode of fantasy nobody will ever consider to equip with an SBrick.

    Come on, guys, whatever set selector you chose here - it definitely was the wrong choice for this project. Why don't you just list the sets that actually HAVE power function items? We're talking of a small subset - A handful of technic models and the train sets. And make it searchable by keyword and number - The year it was issued is a complete trainwreck when it comes to selection criteria. I either have to dig through a few years of sets, or look up the year of issue on BL first.

    I sincerely hope that by the time the SBrick will be available you also will have a usable App.

    Will you provide documentation on the SBrick communication protocol? Or maybe provide a usable, documented API? So far, I haven't written an Android application before, but with the cuttent state of the app I'm tempted to start one.

    Leg bedre,

    Christian

    • 26 posts
    December 14, 2014 3:46 AM CET

    That gives me an idea:

    Maybe the sBrick team can integrate BLE support for android phones and tablets that are on 4.2.2 or lower but have bluetooth 4.0. I think that it should work if it works with external bluetooth 4.0 sticks.

  • December 13, 2014 10:56 PM CET

    Thanks for your help! I'll try Lenovo first, and hope there're no dirty cheap options. :)

    • 87 posts
    December 13, 2014 10:22 PM CET

    BT 4.0 includes Low Energy (BLE), see http://en.wikipedia.org/wiki/Bluetooth#Bluetooth_v4.0

    That's why if your phone has BT4.0 it probably has BLE (unless the vendor made some dirty cheap options, but yours is a Samsung so I doubt it).

    But Google only included support for the BLE part with Android 4.3, that's why you have BT working but only like BT 2.x or BT 3.x. So if you can upgrade to Android 4.3 or even better 4.4 then you will get full BT 4.0 (meaning also BLE) withou loosing anything. You said your phone is rooted so you have more upgrade options.

    The gateway option in another topic with USB OTG will work...but only when Vengit includes support for it in the SBrick App for Android... and they're still at 0.0.16, an alpha version. So if you want SBrick with your S2+ in a few weeks your only option is the upgrade.

  • December 13, 2014 9:56 PM CET

    S2+ already has 4.0. Maybe I can flash 4.3 or 4.4 custom fw on it, but BLE is not backward compatible, is it? So I'm not helped with Android 4.4 and BT 4.0, if BT chip in phone doesn't support BLE itself...

    What about bluegiga ble112 dongle and android app, mentioned in another topic? I already have USB OTG and rooted phone. :)

    • 87 posts
    December 13, 2014 9:43 PM CET

    Well, here it says it has BT 4.0

    http://www.gsmarena.com/lenovo_a536-6674.php

    But you know, don't trust everything you read on the net.

  • December 13, 2014 9:32 PM CET

    Hi Jorge,

    I have Samsung Galaxy S II Plus, the last firmware is 4.2.2, no chance to get 4.3. When I ordered the SBrick, I read a lot after the phone, and it seemed it has 4.0 LE, but only today tried to download the app.

    I planned to buy a cheap Lenovo A536 with android 4.4, but I don't think it has 4.0 LE.

     

    • 87 posts
    December 13, 2014 9:24 PM CET

    Hi.

    If your phone has BT4.0 most probably has LE also, just missing Android support... what's your Android version? 4.3 (or above) has BLE support so if your phone is 4.2 you «just» need to upgrade (easier to say than to do).

  • December 13, 2014 9:17 PM CET

    Hello all Developers!

    I ordered an SBrick in july, I'm an early adopter. Today I got the message that I will receive my brick in days/weeks. Hurray!

    So I thought I have to try out the android app in time, for no surprise.

    I recognized that my phone has BT4.0 but no LE. I can't buy other phone because of the lego remote controll function, so what next?

     

    thx Laci

    • 3 posts
    December 13, 2014 12:31 AM CET

    Hi Jorge

    Thank you for your full test. The sbrick scanner function today we fixed (release in next version), tomorow we see the port tester problem. My collage working on Joystick - gyro position because somewhere that send strange positions.

    thx Zoltan

    • 87 posts
    December 13, 2014 12:09 AM CET

    0.0.16, Sony Xperia Z1, Android 4.4.4

    First run, Manage bricks now shows my SBrick (previously nothing showed up). 3 actions available (Identify led, Port tester and OTA):

    Identify led (does nothing)

    Port tester shows 4 horizontal slides (A, B, C, D) and 4 buttons (reset A, reset B, reset C, reset D) like when editing My linked Sbricks

    but slides seem wrong:
     slide A controls port C
     slide B OK
     slide C controls D
     slide D does nothing but perhaps controls A (A is one of the ports I had problems since the beginning in my python tests)


    OTA: " function available soon"

    This was first run. Next runs and Manage bricks show nothing again. Don't wanto to clear all aplication data again to see if it works again.

    Edit: Powering off the SBrick and turning it on again seems to bring it again so perhaps it has something to do with BLE session.

     

    I now have "Joystick" profile. It gives two controls: Steering and Acceleration. With a motor on A and mapping Steering to A i can control the motor with the position of the phone (there is also a enable button on the display, On/Off, so this control works only when On).

    At the Linked Sbricks, SBrick channels still wrong: B and C are switched, A and D are OK. Strange because in "Manage bricks" B it's OK. More strange: A is working !? What a mess!
    And if tap the arrow it shows "SBrick Port tester", the same 4 slides and 4 reset buttons as above

     

    "Steering wheel 1" and "Steering wheel 2" profiles seem the same as "Joystick": two vailable controls (Steering and Acceleration) and one On/Off button on the display whem running, the only difference seems the location: sw1 in one corner of the display and sw2 in other corner.

     

  • December 12, 2014 1:15 PM CET

    Hi, Javier,

    Thanks for the tip. I'm having a loot at it tonight. I wonder why they start with 1965, when Power Functions popped up no earlier than 2008.

    Sadly there is no documentation yet. If you need someone to help, to proofread, whatever, just drop me a note. I could do a German translation, too.

    Leg bedre,

    Christian

    • 12 posts
    December 12, 2014 11:27 AM CET

    Hello Christian.

    There is no documentation available yet.

    When you click on "add sets", you hace to realized that in the top of the window, at the right of the Sbrick logo, you can see Lego Models years, beginning with 1965.

    You have to pass across the years moving your finger from right to left or you can choose one year, using the menu key of your phone and only one option is activated "Select Year" and a list with all the years are shown. Then you can select one year and all the models of this year are shown. This function is not clear and I don't know the sense of this but...

    I also wonder if the source of the SBrick will be open source in the future, at least the source of the APP.

    Cheers!

  • December 12, 2014 10:25 AM CET

    Just a few questions about the SBrick software.

    Is the source of the SBrick software available? Do you intend to make it available at a time in the future? Alternatively, is there a public available android library/API for the SBrick?

    At the moment, I'm less than impressed with the software - I donwloaded it yesterday and I clicked on "add sets" and it only gave me the oddest assortment of sets one can imagine - it looked a bit like "the ten oldest LEGO set on bricklink" or something like that.

    Is there any kind of documentation available for this?

    Leg bedre,

    Christian

    • 3 posts
    December 11, 2014 8:20 PM CET

    Well, I just spent in 4.4.2, and that's ok.
    It's just that I do not like change version if everything works ....

    Going to see to buy 4 Sbricks .... :p

    • 167 posts
    December 11, 2014 5:43 PM CET

    I hope you'll change your mind :)

    • 3 posts
    December 11, 2014 5:41 PM CET

    OK, thank,

    pity, I will not order the Sbrick on, so ...

    • 167 posts
    December 11, 2014 5:30 PM CET

    You need at least Andorid 4.3 to install the app. The S4 active does have BLE, so that shouldn't be a problem.

    • 3 posts
    December 11, 2014 5:27 PM CET

    Hello

     

    No supported whitch à Samsung galaxy S4 ative (GT-I9295) Android 4.2.2.

    It is possible to have the .apk file ?

     

    Thx

    • 167 posts
    December 11, 2014 1:52 PM CET

    Sariel sent us the following bug report. I'll leave it here for the droid devs:

    Hi Tamas,

     
    Thank you very much, I have downloaded the app and all the profiles. Sorry to be a problem, but literally none of them works. I made sure the SBrick is connected and visible, I made sure the outputs are set, I can't find the problem.
     
    Here:
    - gamepad1: sometimes loads as an empty black square. When I touch the pad, a white circle appears on the lower right corner. Motors don't respond.
    - steeringwheel1, gamepad2, test1, joystick: it loads empty. No controls, just the background.
    - test2: it shows 4 sliders at first, but every time I start it again there is one slider less: three, two and now just one. Motors don't respond.
    - steeringwheel2: it makes the app crash.
     
    Any solutions? I would be happy to buy a newer SBrick prototype from you, but it looks like a software problem.
    • 167 posts
    December 10, 2014 11:28 AM CET

    Hello, thanks, investigating, and yes, preloaded profiles would solve such issues.

    • 12 posts
    December 10, 2014 8:48 AM CET

    Hello.

    I installed version 0.0.15 of the App and now the Market does not show any profiles and there is not feedback when I push the "search" button.

    I have reinstall the App and I have the same problem.

    Could be possible to have one or two profiles precharged in the App?

    • 4 posts
    December 8, 2014 4:38 PM CET

    Ok, removed the app and re-installed the SBrick app.

    Now I can load my profiles again.

    Of the 5 proflies:

    • Test 1 (2 vertical slide bars and 2 buttons) --> OK
    • Test 2 (4 vertical slide bars)                      --> OK working again
    • Joystick --> App still crashes (as before)
    • Gamepad 1 (1 joystick button) --> Now bigger button not working NOK
    • Gamepad 2 (2 slide bars 1 hor 1 ver) --> Still working