Forums » Support

Back To Topics

SBrick Android App

  • April 6, 2015 7:10 PM CEST

    @ Frederic

    Thank you for the information.

    OK, I have 4.0
    How do I get 4.2 ???

    • 95 posts
    April 6, 2015 6:59 PM CEST

    [blockquote]Karl Fensterstock said:

    Is there a way to check which firmware version is installed on my Bricks?


    I this when the sbrick is powered with 4.0 firmware the status led id off

    and it is on when the sbrick is running 4.2


    • 7 posts
    April 6, 2015 4:56 PM CEST

    [blockquote]Karl Fensterstock said:

    Is there a way to check which firmware version is installed on my Bricks?

    [/blockquote] firmware 4.1 iOS returned northing (known bug). don't know if 4.1 returns any information when checking 'manage bricks' on android. firmware 4.2 iOS still returns nothing and crashes. android only reports the request to update but no firmware version. this request returns in a endless loop.


    acording to the wiki documentation:

    Each SBrick has a unique screen which will list the following information for the SBrick selected.

        SBrick name
        Icon (identicon)
        Firmware version
        Power supply voltage
        When the SBrick was registered
        Time spent online (minutes/hours/days)
        Counter showing the number of commands the received so far
        Security status (public/secured, users have been granted access)
        Firmware version
        Rename button, allowing you to change the SBrick’s name
        Lighting up or down the Identify LED.
        Port testing button, allowing you to jump to the Port Testing screen




    This post was edited by Michael H. at April 6, 2015 5:09 PM CEST
  • April 6, 2015 4:48 PM CEST
    Is there a way to check which firmware version is installed on my Bricks?
    • 57 posts
    April 6, 2015 3:52 PM CEST

    Any official comment about the status where we came?

    Did you found the root cause?

    I know modern software development means little testing and let the end users find the bugs, but I wonder how can we let escape a bug like this... Don't take me wrong I'm still very supportive to this project. :)

    • 13 posts
    April 6, 2015 8:31 AM CEST
    @Norman C., @Michael H.
    I think vengit was going to soon on the Android market. And for some reason, I will never buy an iOS device. That's why I bought an sbrick which also should work with Android.
    • 7 posts
    April 6, 2015 6:36 AM CEST

    Hi, I upgraded to 1.0b and facing the same issue on my Nexus 7 (2013) Android KitKat 4.4.4. Endless request for firmware updates makes it impossible to use the sbrick any longer it is just a lopp-until-death trap :( Even more worth is the fact, that I can not use my sbricks with an iPhone  any longer because the iOS app crashes when starting a new created or old profile. I am sorry to say, that the sbrick is the worst sh... I ever spend my money for. We are waiting since ages to get a working android app. But what we get are buggy and non working alphas. I'm tired of waiting, angry about my optimistically founding at kickstarter and will sell the trash on eBay. 










    • 24 posts
    April 5, 2015 10:29 PM CEST


    Vengit knew what Android phones were like before they ever offered an Android app so to say that it is the phone manufacturers problem is nonsensical.  However, if they DIDN'T know about Android phones then they are so naive as to be unbelievable and not fit to be running any sort of business.  Do you really think that the phone manufacturers got together to make all the variations of Android just to mess up the Sbrick?  Of course not and Vengit knew what an Android app entailed before they ever offered it.  They have just not got sufficient skilled developers to deliver what they promised.

    Of course the problems from the iOS side have been much less because that is what the Sbrick was designed to work with.  In my opinion Vengit offered an Android without thinking what it entailed just to ensure that there were sufficient people signing up so that they could reach their funding target.  With their target being exceeded by only approximately 30% I would suggest that without the Android sign-up they would have failed to reach their target and the Sbrick might never have happened.

    As to your legal action comment, if you read it again you will see that I specifically excluded any action by Kickstarter members, myself included.  However, when the project goes live any later purchaser may have no knowledge that this was originally financed by a Kickstarter subscription.  They have just bought a product that was specified to work with any Android device from version 4.3 on.  This is what they are entitled to receive.

    "Be patient, it'll work very soon." Having gone through every version where this was promised I am beginning to doubt it, unless your definition of "very soon" is in the next year,



    This post was edited by Norman Chalcraft at April 5, 2015 10:35 PM CEST
    • 4 posts
    April 5, 2015 9:55 PM CEST

    Hallo Norman,

    I find your post a bit on the harsch side.

    the main problem is not with the app disigners from Vengit but with the android phone manufacturers who ALL want to implement their own apps, programms, preverences, rules and in some cases even their own app store.

    You never hear this kind of crap from the IOS platform so where do you think the problem lays? with Vengit? Don't think so! It's every android phone manufacturer making sure that only their shit works without problems.

    And about going into the realm of legal actions against a kickstarter project?? That's really funny. Kickstarter projects are about giving someone a fair chance to realise their ideas. If the idea doesn't work, to bad!! this one does seem to work howevever and the guys working on it invest alot of time to make it work for all the idiotic android spinnoffs from every phone manufacturor as well. Be patient, it'll work very soon.

    Regards, E.

    • 24 posts
    April 5, 2015 9:22 PM CEST

    Samsung Galaxy S3 running Android 4.3.

    Congratualtions to Sbrick for actually issuing an update when they said they would.  Well done!!

    However, just issuing any old rubbish that happens to be around isn't really what we all expected.  I cannot believe that this new version was actually tested before being allowed to escape.

    After going through all the problems that others have experienced with multiple OTA updates, un-installing and re-installing, turning bluetooth off and back on and turning the phone off and back on I've finally - after an hour or so - got to the point where I can discover a Sbrick without having to update it.  From it's reaction to the port tester the response seems very good.  However it would be nice if the Identity LED actually turned off and on instead of being permanently on!

    Finally, I get to building a control set.  The creation builds quite nicely and accepts an Sbrick without requiring an update and accepts a standard profile.  Great!  All I need to do now is to save it.  To do this it would be nice to be offered that option but no matter where I look there is no option to save a creation.  The consequence of this is that I can either edit the creation or delete it but actually use chance.

    I'm in the unfortunate position of being an early Kickstarter backer and thus accept that if I subscribe to absolute rubbish it's my own fault.  If I'd purchased my Sbricks after the Kickstarter campaign I'd be looking at legal action for a refund and expenses.  With Vengit being based in London and with the UK's  Consumer Protection Laws the advice I've been given is that it'd be a bit of an open and shut case as no defence appears possible.

    Come on Vengit - either publish a working Android app or finally admit that an Android application is beyond you and start arranging for refunds!

    • 21 posts
    April 5, 2015 8:14 PM CEST

    After another reinstali i can run profile. But invert for servo doesn't work.

  • April 5, 2015 7:15 PM CEST

    Everything works fine, just the two bricks do not.

    • 41 posts
    April 5, 2015 5:31 PM CEST

    I have some news..... i uninstall the sbrick app, restart the phone and install the sbrick app again.

    But now i go directly to the profile section (Don't go to the manage sbrick menu!!!), discovery the sbrick and update the firmware in the profile menu. When you are done with the update a screen shows ("update ok or something"), when i press OK the app crash, so.... i inmediatly restart the phone. Once the phone restart i enter the sbrick app and make a new creation, now i can select the sbrick without any update dialog. FINALLY!!!! Testing with a MOC (it's a Car) and works fine.....also i download my "test" profile and works fine.....the delay now is really minor, if can be reduced a little more will be perfect.



    - If i exit the app and want to use the profile i made for this MOC (play later for example), the discovery sbrick dialog stay forever.....can't discovery the sbrick. The only solution is to delete the MOC Creation profile and do all the process to add a creation (select the profile, select the sbrick, select the channels, etc.) in order to use it again.

    - Manage Sbrick menu is buggy.....firmware update CAN'T be done in that menu.

    - The App crash time to time.

    - Joystick type profile don't crash.


    This post was edited by Denis H at April 5, 2015 8:19 PM CEST
    • 41 posts
    April 5, 2015 4:29 PM CEST


    Yes, i restart the BT every single time i update, also restart the phone, also uninstall sbrick app, restart the phone, install sbrick again....i have the same issue, firmware update over and over again. Impossible to use the Sbrick.

    Also tried with a Samsung Galaxy TAb4 10.1 (android 4.4.2) with the same Sbrick....same problem, firmware update over and over again.


    During testing..... i have already update the firmware 20 times, and still the app ask me for a firmware update.....THIS IS NOT NORMAL!!!

    This post was edited by Denis H at April 5, 2015 4:32 PM CEST
    • 4 posts
    April 5, 2015 4:03 PM CEST

    @ Zsolt Majoros,

    With "one function, 2 ports" do you mean controlling 2 ports on SBrick with one slider?

    This is what I want to do but I'm unable to get it to work.

    regards E. 


  • April 5, 2015 3:34 PM CEST

    I now Ver. 1.0b installed on my Livetab.

    After that I started the app and turned on the SBrick.

    After logging in and downloading the profiles ...

    ... I start "Manage bricks" whereupon the following screen appears.

    After about 10 seconds the message "Discovering Bricks" disappears and I see the following ..

    If I select them the Sbrick then comes the following ...

    END !!! That's it, that's all about.

    PS: The same problem of course with both! Bricks !

    The "SBrick Simple" works without problems !!!





    This post was edited by Karl Fensterstock at April 5, 2015 3:51 PM CEST
    • 57 posts
    April 5, 2015 3:18 PM CEST

    I decided to give it a try with another SBrick, so I unpwered the first and powered the second one.

    It pairs with phone as second and distinct device.

    Although SBrick App continues to see the same SBrick ID and MAC address (00:07:80:2E:39:F2) which is quite weird and probably related withe the root cause of the problem with my device!?

    Hope this helps you to find where the bug hides...

    It might be an update problem similar to what observed with the market profiles. After moving into another men and return to "Manage bricks", it displays the right MAC Address.

    Tried it also with Samsung Galaxy Pro 12.2 (4.4.2). Same issues!


    Have a nice Easter. ;)

    This post was edited by Fernando Correia at April 5, 2015 3:41 PM CEST
    • 57 posts
    April 5, 2015 3:09 PM CEST

    Also tried to rename SBrick in my list of paired devices to "SBrick #01", but app continues to find it as "SBrick".

    Maybe it doesn't care about the name defined at device level and relies at manual rename at the App level.


    Find also another bug.

    When I download profiles from the market, App never remembers about the last downloade profile. If I delete another one and download it again than that's the last one and it doesn't remember its download status.

    However if I switch to another menu (e.g. Home) and switch back to Market menu, then it displays the downloaded profiles correctly.


    • 57 posts
    April 5, 2015 2:46 PM CEST

    Same problem here!


    Smartphone: Samsung Galaxy Note Edge

    Android OS: 4.4.4


    App keeps asking to update SBrick firmawre afther having already done so.

    Restarted BT, Sbrick and even the smartphone. Also tried to uninstall SBrick App and installed it again.


    I'm confient you'll find the issue and provide a fix soon. ;)

    • 13 posts
    April 5, 2015 2:46 PM CEST
    This is now my test:
    Deinstalled 0.8. After that installed 1.0b. Sbrick is found and said that I have to update. After update is complete there is a message like :"Could not connect to sbrick. Out of range or powered off..."

    Then message: "sbrick firmware update completed"... Clicked ok.

    Then message : sbrick was terminated and it restarts by itself with a blank screen and sbrick logo. When I go back there is every time my creation one more duplicated.

    And when I restart Bluetooth like I should, it's thesame. The sbrick is found and when I click on it, it says that it is not up to date. I can't select the sbrick for port test, I can only update or cancel, nothing more. So far on our Moto G2.
    Happy easter to all of us
    • 21 posts
    April 5, 2015 2:23 PM CEST

    [blockquote]Denis H said:

    BUT now everytime i want to use the sbrick (select in the port tester or profile screen) the app ask me again and again and again that i need to update the firmware (i already update the firmware 6 times)...i CAN'T USE THE SBRICK!! the app always ask me for an firmware update, all updates are OK. [/blockquote]
    Strange, in my case the app only once requests for update the firmware after updating. And I rejected this request.
    Do you try to delete completely the app and reinstall it? 

    • 34 posts
    April 5, 2015 2:20 PM CEST

    For everybody who updated the firmware and the app asks for another update, did you restarted the device's bluetooth?

    "one function, two ports" and more sbrick support will be solved next week.

    We'll fix the other problems also next week, thank you for your feedbacks.

    • 41 posts
    April 5, 2015 1:37 PM CEST

    Test the new 1.0b version of the app on my Samsung Galaxy S3 (i9300).... the app ask for an firmware update, i successful update the sbrick. BUT now everytime i want to use the sbrick (select in the port tester or profile screen) the app ask me again and again and again that i need to update the firmware (i already update the firmware 6 times)...i CAN'T USE THE SBRICK!! the app always ask me for an firmware update, all updates are OK. Also the app crash time to time (fortunately not during the update process). this point clearly you don't have the skill to make an android app for your own product....i suggest to hire a guy who knows about android development. I'm very disappointed with your product overall....we will have to wait another month for an update? 

    • 7 posts
    April 5, 2015 1:22 PM CEST

    I have the new S-Brick app installed. Then, the firmware should be updated on the S-Brick OTA. I did that. Now the S-Brick fail to connect ("could not connect to sbrick, it might have been power down, or gotten out of range") and the LED is permanently on. What can I do?

    after a lot of hours with very very many app crashes, a lot of force stops, cleared data and with a lot of restarting Bluetooth, App and SBrick now it works. (HTC One S Android 4.4.4)


    This post was edited by Tanja Causemann at April 6, 2015 9:58 AM CEST
    • 21 posts
    April 5, 2015 12:46 PM CEST

    Samsung S3 i9300

    In port tester, i havn't delay anymore. This is a very big step forward, as for my.
    Also i updated firmware my sbrick (for the first time).
    But i can't run any profile in "my new creation" - app is closed.

    For my phone model its a progress. Thanks!