Forums » Support

Back To Topics

SBrick Android App

    • 17 posts
    January 2, 2015 6:51 PM CET

    I would probably describe it as Alpha rather than Beta considering most of it doesn't work, especially in comparison to the iOS one. (Which is an entirely different looking app)

     

    Generally, at the moment the port testers work most of the time. The LED tester only work on rare occasions.

     

    Amusingly, I have an S4 which can connect to the brick but with a very unstable and unfunctional app and a Apple 4 which has a nice app, but can't connect. Fun and games!


    This post was edited by Toku Betsu at January 3, 2015 6:11 PM CET
    • 28 posts
    January 2, 2015 6:45 PM CET

    Just received my SBrick in the mail. Installed SBrick app v0.0.21 from the Play Store.

    I have a Nexus 4 running stock Android 5.0.1.

    Here is my feedback for the app:

    • I cannot delete Sets.
    • When I try to remove Linked Profiles while editing a set the app crashes.
    • I cant get any of the profiles to control the SBrick.
    • Using "Identify led" and "Port tester" is the only way that I can control the SBrick.
    • As soon as I try any of the linked profiles in a Set, the menu becomes unresponsive. I can slide it open but none of the options work.
    • The market only loaded once.

    I hope this helps yous guys somehow.

    Unfortunately I cannot control the SBrick in order to control my creations.

    Let me know if there is anything that you would like me to try out and give you feedback!

     

    • 34 posts
    January 2, 2015 4:16 PM CET

    Would you provide your SBrick connection status to the statistics thread I tried start ?

    https://social.sbrick.com/forums/topic/68/device-sbrick-connection-compatibility-statistics/

    It should not replace this one, just used for collecting pure statistics on which device type/model is generally connecting OK or not.

    • 25 posts
    January 1, 2015 3:49 PM CET

    Hi gents,

     

    Give feedback (always useful for developers - include your android version and phone/tablet model), but keep in mind that the android actual version of the app is still in development, it's a beta version just released for us to test our just received Sbricks and be able to play a little bit during our vacations.

    After all efforts done to have the hardware ok and send it, I think Sbrick team can have a little rest during this holiday period, even if we are also on holiday, with our Sbricks, impatient to see them animating our models.

    Let's be comprehensive and patient... Roma did not get built in one day!

     

    Sylca (simple backer)


    This post was edited by Sylvain CACHEUX at January 1, 2015 10:47 PM CET
    • 9 posts
    January 1, 2015 10:59 AM CET

    [blockquote]Zsolt Pogonyi said:

    Hi Everybody!

    I can't pairing my phone with SBrick. I have Sony XPeria SP, Android 4.3, BLE Checker say BLE Supported. nRF Master Control Panel can connect, without previosly pairing. SBrick LED blink shortly after switching power on. I tried it with AA batteries (8881) and rechargeable battery box (8878). My phone bluetooth settings found the SBrick, but can't pairing. I have the latest SBrick Android App version 0.0.21 and this can't discover SBrick. Please help!

    [/blockquote]

     

    Hi same phone, same problems. The first time I was able to pair with SBrick, but since the older version of the app didn't work, I unpaired the devices in order to start the whole procedure again - then I couldn't pair my devices anymore. I tried to clear the bluetooth cache, but it seems it doesn't clear right, there are always 12kB of data in cache that just won't go away. I tried the same on XPeria M, first time pairing wnet ok, app was working, after unpairing, no pairing could be done again!

    • 1 posts
    January 1, 2015 5:09 AM CET

    Seems to be a huge gap between the current app version 0.0.21 and what is shown in some of the promotional videos.  

     

    And certaily acts like 'alpha' software.  Certainly has a lot of potential.  Is there a timeline for a beta release that might be more usable and closer to some of the promotional videos?  

     

    Thanks,

     

    Ben

    • 3 posts
    January 1, 2015 1:12 AM CET

    Hello,

    I currently have a fully up to date samsung galaxy note 3, I am having trouble controlling my creations at all. The profiles in the app can't be adjusted, and for some reason the motors I am trying to power are acting really weird. I can't wait till the adroid app catches up with the ios one because right now it's between the android app and my iphone 4s which isn't exactly compatable with the app screen size wise (more details in the ios forum...). Bottom line, I can't easily control my creations so I hoping for a some serious updates. I know you guys are trying your best, just trying to share my experiences so far... 

    Thanks,

    Justin

    • 34 posts
    December 30, 2014 11:38 PM CET

    [blockquote]Sylvain CACHEUX said:

    ...

    Interresting point: when having a pb with a profile, go to market, delete profile, then redownload it and it works better! (does not work with joystick or gamepad 1 for me - sometimes app crashes when deleting the profile in the set edition)

    ...[/blockquote]

    Thanks. Your confirmation of this behavior had me trying again and succeeding.

    I want to add, that for the profile to reload I needed to remove it from all MOCs. I tried deleting it from market before and it failed reloading, but left it linked to one of the early MOCs. 

  • December 30, 2014 11:22 PM CET

    A profile type for 42030 (or other officials models) exist in market?

    • 25 posts
    December 30, 2014 6:18 PM CET

    Hello,

     

    I went with further tests.

    Test1 profile is ok, but button does not switch off the lights (light turns on, but when switching off the button, displays shows it off, but light are still on). Interresting point is that it's possible to have all range of lighting with a slider, not just on/off !!! That opens possibilities! Note: sometimes, when releasing the slider, it comes to center, but the motor is still working.

    One useful thing would be to have a reminder on the profile's displays with which slider is "slider 1", which is "slider 2", etc. (idem with buttons). That would help a little bit (even maybe add to which port it's linked!).

    Profiles which uses gyro are not really working well with my phone (Samsung Galaxy Note 2). Impossible to get them work correctly (zero or full speed, direction not taken in account, etc.).

    Joystick or gamepad 1 (display pb - the joystick stick does not appears) not working either. Gamepad 2 also have pb, impossible to get it work, and displays seems to be corrupted/distorded.

     

    Interresting point: when having a pb with a profile, go to market, delete profile, then redownload it and it works better! (does not work with joystick or gamepad 1 for me - sometimes app crashes when deleting the profile in the set edition)

    I know it's still under development, it's just to give you a feedback :-)

    See you later... (and warn me if you need a test :-) )

    Sylca

    • 1 posts
    December 30, 2014 10:52 AM CET

    Hi Everybody!

    I can't pairing my phone with SBrick. I have Sony XPeria SP, Android 4.3, BLE Checker say BLE Supported. nRF Master Control Panel can connect, without previosly pairing. SBrick LED blink shortly after switching power on. I tried it with AA batteries (8881) and rechargeable battery box (8878). My phone bluetooth settings found the SBrick, but can't pairing. I have the latest SBrick Android App version 0.0.21 and this can't discover SBrick. Please help!


    This post was edited by Zsolt Pogonyi at December 30, 2014 1:27 PM CET
    • 25 posts
    December 30, 2014 9:22 AM CET

    Hello,

     

    Just a suggestion: as there is more and more profiles, it's becoming a little bit hard to remember which one have sliders, or steering whell, or light switches.

    So it would be very nice that, when selecting the profile, we could have a little image of the controlers, just to quickly see which profile it is really in terms of controlers.

     

    And as previously asked, inverters for each port would be very nice to have.

     

    Thank you :-)

     

    Sylca


    This post was edited by Sylvain CACHEUX at December 30, 2014 9:22 AM CET
    • 10 posts
    December 30, 2014 1:59 AM CET

    [blockquote]Maxim Baybakov said:At least we have three people with a problem "discovering sbrick..." using Galaxy S3. I hope we will not stay without attention![/blockquote]

    Make that 4...

    • 17 posts
    December 30, 2014 1:34 AM CET

    They should put the profile for the 42030 up on Market if it works. At least people could do something with it.

    • 4 posts
    December 29, 2014 11:20 PM CET

    [blockquote]Sylvain CACHEUX said:

    Edit: I uninstalled the app, reinstalled, redownload the market, recreate a new moc profile, and this time it worked! I do not know what changed, I guess the cache has been reset.

    [/blockquote]

    Same here, Android app crashes and you can't save an sbrick in a moc until you uninstall and re-install.

    As mentioned elsewhere the brick makes a high pitch whine when operating, and there's no obvious way to reverse inputs it seems. Also noticed that sometimes on 'releasing' a slider the motor not stop, and you have to tap in the middle position when the control already is to stop or centre.

    All that, given it's in Beta and I've got it working within an hour I'm quite happy :-) Just have to remember down is forward, and up backwards...

    Iain

    • 34 posts
    December 29, 2014 10:34 PM CET

    Which profile did you use ?

    No problems with reversing inputs ?

    • 2 posts
    December 29, 2014 10:32 PM CET

    Just tested one of my Sbricks for the first time. First time right! Love it. Using Sbrick 0.21 on a Samsung S5 mini. Ultimate control, 4 slider controle, over the 42030.

    The only thing I notice; it creates a very high pitched sound when active. Is that normal?


    This post was edited by Michel Scheffer at December 29, 2014 10:33 PM CET
  • December 29, 2014 8:35 PM CET

    It's good. I buy a Samsung Galaxy Pocket 2 (SM-G110H) in 4.4.2 Android version and V4.0 Bluthoot. I DL apps in first time. It's OK for sinchronise a smartphone and SBrick. But don't find a commands for my 42030. I make it?

    • 17 posts
    December 29, 2014 8:12 PM CET

    Okay, has anyone manage to get any profile to work on a Galaxy S4? I removed them and downloaded the current set (Including Test 1 & Test 2 now.) None of them do diddly squat.

    The bit which amazes me is the ports work perfectly via the Manage Brick test interface. Just create a section of the interface in the APP where we have better access to those 4 sliders. At least then people can do some stuff.

     

    Another thing I have noticed, is that you can't delete the sets you have created under My Sets. I removed the profiles from each one, then tried to remove the Sets themselves. Nothing. Delete icon does nothing. So be careful not to create to many Sets.

     

    Just imagine if the SBrick has been shipped out at the original release date :)

     

    I don't mind the release of the SBrick before it is really ready, just because the Test ports part of the App shows you what it will eventually be capable of. Just gotta sit tight a while.

    • 24 posts
    December 29, 2014 12:23 PM CET

    Thanks to Tamas for publishing the communications protocol in the forum Suggestions.

    Using this information together with the utility nRF Master Control Panel I have been able to control my Sbricks.  This shows that there aren't any significant problems with the Sbrick itself, it is just major problems with the Android app.

     

    • 24 posts
    December 28, 2014 7:05 PM CET

    Uninstalled Sbrick app and installed new version from Playstore, version 21, on to my Samsung Galaxy S3 running Android 4.3.

    Changes?  None in performance that I can see!!  Still can't add a set only a MoC.  Still can't discover any Sbrick!  Only change that I can see is the version number!

    • 10 posts
    December 28, 2014 4:00 PM CET

    [blockquote]Toku Betsu said:

    My SBrick app updated last night. Was previously on 0.0.20 and is now 0.0.21. Apparently a scan fix has been done.

    [/blockquote]"Apparently" yes, because I see no changes on my LG G2. SBrick visible in Bluetooth menu of the phone, but SBrick App can't find it.

     

    Also the LED doesn't go on, it just flashes for a fraction of a second when you turn on the power. Not sure if this is normal behavior?


    This post was edited by Nick Matthews at December 28, 2014 4:06 PM CET
    • 4 posts
    December 28, 2014 3:43 PM CET

    Yesterday I resived my SBrick.

    After powering on the SBrick the manual says the LED should turn on. I did not... I though is my SBRick broken.

    But after 2 times re-installing the App my Samsung S5 I was able to operate the SBrick.

    I found that the LED is working if your turn it on in the Manage Brick menu (identify led).

    I installed the SBrick on my 41999 and only profile Gamepad 2 was working, except the speed control was working reverse.

    I don't know who to reverse the output controls.

    The Joystick does not work at all and the steering profiles do not react very well.

    Gamepad 1 does not work at all, sometimes the app stoppes. Test 2 only shows 1 slider. So I probably have to re-install the app again..

    I also installed the SBrick app on our IPAD (software 6.1.3.) and IPOD but both cannot find the SBrick....

     

    I hope the software bug will be fix sone

    • 25 posts
    December 28, 2014 3:27 PM CET

    Hello everybody,

     

    I'm running the app version 0.0.21, on Samsung Galaxy Note II, version android 4.4.2.

    The market is ok, I managed to download all profiles.

    With the Sbrick manage bricks, I find a sbrick, the identify led works (I noticed that last time I tested, the 2 first on/off, it did not worked, then the 3rd time it worked), the port tester works with all ports, and the OTA (???) indicates that the function will be available soon.

    When I select the home page in the menu, it just displays a welcome message. When taping on it, it displays a kind of controler (joystick, black screen with white border, ...) but nothing happens on Sbrick.

    When I select "my set", I tap the "+" and create a new profile via the "add new moc button (no possibility to add an existing lego model). This adds a profile. When taping on it, I can rename it, then change its image. I can also find my sbrick (discover is a bit long). Then I tap on the Sbrick to set the ports, which works. I tap "save your set!" button and ... it crashes. Impossible to save. If I tap on the profile before, it opens the profile screen (with buttons, sliders, etc.) but it warns me that "couldn't discover all bricks!" with cancel and retry button. Retry redisplays the same message, and cancel let me on the profile, which is obviously not working.

    I tried to change the port on my Sbrick, but same error, the app is crashing, returning to my phone screen when saving my set. I manage to change the profile, and go into the sbrick ports, but always crashing when saving.

     

    Edit: I uninstalled the app, reinstalled, redownload the market, recreate a new moc profile, and this time it worked! I do not know what changed, I guess the cache has been reset.

    It may be helpful for others, that's why I'm posting :-)

     

    So that's all I can test for the moment...

     

    I guess you guys take some rests with your families during the holidays, after all the work you did with the hardware part, and think the app will be improved in january!

     

    Best regards,

    Sylca


    This post was edited by Sylvain CACHEUX at December 28, 2014 3:32 PM CET
    • 17 posts
    December 28, 2014 3:12 PM CET

    My SBrick app updated last night. Was previously on 0.0.20 and is now 0.0.21. Apparently a scan fix has been done.